How to exclude sourcenodeid for zwave devices

I’ve added some multisensor devices to my zwave network, and they show up in the overview OK, but I’m getting many more entities showing up than I want.
In particular is the SourceNodeId which is of no interest to me!
Is there a way to choose which entities you want to have show up in the UI? Or even remove from HASS altogether.
Thanks in advance.

Add this to a Zwave_glob.yaml config file:

  ignored: true

Thanks, will try it, just rebooting …
Noob error, I cut an paste your code into a terminal session and found that it inserted loads of spaces for the second line.
Another reboot …
No, still not working. Is the Z in the filename to be capitalised ?


Does your configuration file reference to a global zwave config file? You would have set that up manually.

If yes, insert it into that file - whatever it’s named.

If not you can put it in your config file under the zwave: node

The docs will show examples.

But once that is in the right place it will prevent all sensors devices sourenodeid’s from showing up.

Thanks @jwelter, in the end I added it to the homeassistant section of configuration.yaml.

#      ignored: true
      hidden: true

There was a file created called zwave_device_config.yaml

I’m still a little confused about the exact solution here. @kev, do you mean you actually added it to the section called homeassistant in the configuration.yaml?

        hidden: true 

I include all my zwave config in an external file:

zwave: !include zwave.yaml

If I just put the above config inside zwave.yaml, should it work?

Yes, I believe you are correct for where I put it in the configuration.yaml.
The included file might not work, since it is for zwave section.

I fiddled around with this a bit more, and I think the setting that @jwelter was referring to was device_config / device_config_domain / device_config_glob which IS part of the zwave config node. This is where the “ignored” property comes from.

1 Like

Sorry if I mislead you - unfortunately my HA crashed I think due to an SD card issue so don’t have the files to refer to.

No worries. Just wanted to post it so that other people trying in the future would have the reference!