How to find the right path from a zigbee stick


I’m trying to connect my Aeotec Z-wave stick.
Used it a few years, but it’s nog working anymore.
I can’t find it anymore at “system > hardware”.
Do i really have to see the name of the stick there?
Already have a usb extension cord, but that also doensn’t help.

Really strugling here, just don’t understand why is doensn’t work…
The stick flashing different colours when connected.

In the screenshot above, is that the Aeostick?
How do i recognize it?



Are you running on linux? If you are try:


root@hassio:/home/xxxxx# lsusb
Bus 001 Device 007: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 006: ID 10d5:55a4 Uni Class Technology Co., Ltd
Bus 001 Device 005: ID 248a:8566 Maxxter
Bus 001 Device 003: ID 058f:9254 Alcor Micro Corp. Hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

ttyAMA0 sounds familiar, go with the long version (DEVPATH), as the others are symbolic links and may change.

Also: You tagged your post Z-Wave…

Unplug and replug it. Then read the bottom of the output of dmesg.

I’m on an Raspberry Pi 4, Home Assistant installed.

When i type lsusb in terminal i get:
Bus 001 Device 001: 1d6b:0002
Bus 001 Device 003: 0658:0200
Bus 001 Device 002: 2109:3431
Bus 002 Device 002: 14b0:0206
Bus 002 Device 001: 1d6b:0002

Not something a person can read :slight_smile:

As I said.

You are fast, thanks :).

Was trying like a maniak.

Result from unplug and replug:
21-11-16 19:51:35 WARNING (MainThread) [supervisor.hardware.monitor] Ignore device /sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1 / failes to initialize by udev
21-11-16 19:51:35 WARNING (MainThread) [supervisor.hardware.monitor] Ignore device /sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/tty/ttyACM0 / failes to initialize by udev

All of a sudden there is ttyACM0 at the hardware section.

Tried the paths below, still no sigar.

Device path: /dev/serial/by-id/usb-0658_0200-if00
ID: /dev/ttyACM0
DEVPATH: /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/tty/ttyACM0
DEVLINKS: /dev/serial/by-path/platform-fd500000.pcie-pci-0000:01:00.0-usb-0:1.1:1.0

DEVNAME: /dev/ttyAMA0
DEVPATH: /devices/platform/soc/fe201000.serial/tty/ttyAMA0

That‘s the path to use. If it doesnt work, you have either a permissions issue or the stick‘s firmware is bad and needs re-flashing.

The older Aeotec Gen5 does not work with the RPi4. You need to connect it to a USB hub. The newer Gen5+ is compatible.

1 Like

Aha, so a cheap usb with connected to my pi4 will solve it?
Going to try that soon!
An usb extension cable can’t do the thick?
Only a usb hub right?

Thanks for the info :grinning:

The hub is required, but an extension is recommended as well.

My Pi4 begins to look like a real frankenstein

  • Dangling ssd drive
  • Conbee stick with extension cord
  • USB Hub
  • Usb extension cord from the usb hub to the Aeotec Z-Stick