How to fix a bug in dependency of a custom component locally?


I have a philips air purifier and I’m using a custom integration, which has a dependency.

Everything was fine, until a firmware update came for the air purifier, and it stopped working. I cloned both repos, sniffed the messages between the official philips app and the device, debugged it, and actually managed to find the bug, and I’m 99% sure I fixed it. But I want to test it first before submitting a PR.

Updating the integration code was easy, I just copied it to the custom_components folder, but I have to update the dependency too, which is automatically pip installed by ha/hacs. I tried copying it to the deps folder as instructed by the doc page, but it still picks up the old one from /usr/local/lib/python3.9/site-packages/ which (if I understand correctly) is not accessible to me because I am running HA OS and this is a docker container location.

Where can I find the source for the automatically installed dependencies? How can I make HA pick up my version of the dependency?

So I’m not sure if this is the correct way to solve this problem but I can say that this

Isn’t entirely true. If you install the terminal & ssh addon from the community addon’s repo and turn off protection mode you can access the docker cli. This allows you to docker exec into the homeassistant container and make changes.

Again, I highly doubt this is the correct solution. But I think it is a viable workaround.

1 Like

Thanks, with this addon I was able to access the docker container and update the file in question.

I’m still interested in a proper solution though.