How to force Aqara Smart Plug to report its power reading more regularly to HA?

I’ve noticed if I open the zigbee addon and keep clicking on refresh, I will get changing Power values, sometimes by more than 2-3Ws.
Does anyone know how I can force the plug to report things more regularly?
I know the readings are happening at the hardware level but HA is somehow not picking them up.
P.S. I have a few of these smart plugs and most of them I don’t need that kind of precision. But one is tied to a device whose power I want to measure very precisely.

Reporting interval in the Zigbee2mqtt UI.

1 Like

can you explain which one exactly and if i need to touch these endpoint drop downs?

Something like this


So I was only able to add the activePower one, the rest said they were unsupported
Unfortunately, it didn’t seem to help things. I sometimes have power movement by more than 1W and even though I’ve set it to 1, it does not update. But if I got an manually click refresh it does update.
Any ideas what I’m doing wrong?

EDIT: a bit more info, so I tried all sorts of items in the dropdown that “sound like” power but none of them were supported. What’s more, after enabling debug level logs in Zigbee, I’m seeing the following errors which prob explains why this approach isn’t working for me. Do you have any idea how I can fix it? :pray:t2:

Debug 2024-03-30 09:39:08Received Zigbee message from 'Living Room Smart Plug', type 'attributeReport', cluster 'haElectricalMeasurement', data '{"activePower":-1}' from endpoint 1 with groupID 0
Debug 2024-03-30 09:39:08No converter available for 'ZNCZ12LM' with cluster 'haElectricalMeasurement' and type 'attributeReport' and data '{"activePower":-1}'

I don’t have a ‘ZNCZ12LM’ myself, only a ‘ZNCZ04LM’. You can see what clusters are available under ‘Clusters’ on the device page in Zigbee2MQTT.

1 Like

Thanks, I’ve been using zigbee for a while and things always ‘just worked’ so never had to learn much about it. I’m currently using the dev console to probe each point but there are soooo many. Thanks for the idea to check the device page - had not idea that exists so I don’t have to go crazy checking hundreds of points!! I’ll update what I find.

Hmm I don’t see anywhere in the docs where it tells you which cluster is supported and which values within it. E.g. looking at your device “Xiaomi ZNCZ04LM control via MQTT | Zigbee2MQTT” I do not see where you were able to find out that you should use haElectricalMeasurement and then the attribution rmsVoltage.
Apologies if I’m being dense and it’s supoer obvious…

Instead of trying, maybe ask the question on

1 Like

Actually I think if I look at the “cluster” tab for the device it will show me what endpoints/clusters/attributes are supported! I’ll try with that first and if I get stuck, I’ll ask on GitHub. Thanks a lot.
BTW I’m not sure if I can mark any of your answers as the solution… I think probably not since they do not solve the Aqara-specific issue :(.
Thank you very much for taking the time to help me out on this though!