How to get HomeKit devices to show up in Home Assistant

I just purchased and installed a new HomeKit smart plug which HomeKit sees just fine and I can control with HomeKit just fine. However because Home Assistant is my automation tool of choice not HomeKit I would like to get these HomeKit devices to show up in Home Assistant but can’t figure out how to, any help would be great.

Is this not possible? I also purchased a couple of the Anthom smart plugs flashed with Tasmota and from what I can tell those don’t work at all with HomeKit and the company that sold them to me claims they work with Home Assistant but provided no instructions on how. I’m going to be getting a Home Assistant Yellow in March and with it I’m getting a Z-Wave dongle so that I can re-use all my old Z-Wave plugs until they all die.

I don’t use HomeKit or Tasmota myself but it is doable, you need to install integrations for that.

  • Download homekit controller on Home assistant.
  • Remove the smart plug from homekit.
  • Reset the device so it can be connected to new control devices.
  • Open de homekit controller on home assistant and there you go.

Thanks Michael, that really does sound simple but it’s not simple enough for my simple mind. When I open HomeKit Controller the only devices in the dropdown are the devices that came from the HomeKit add-on that really took devices from Home Assistant and exposed them to HomeKit which I’m not sure I need. They were added when HA told me these new items were found and said to scan the code with the phone camera.

I have exactly the same issue! Anyone in this forum who could support us? So all devices that were already integrated into home assistant are visible in HomeKit, however, the other way around is not working. So devices that were linked to HomeKit do not appear in HomeAssistant. To make that a bit more specific… since SkyConnect is still not supporting Thread I used the HomeKit implementation to add one HomePod as ThreadRouter. Unfortunately I can only connect new devices via HomeKit not HomeAssistant, and once they are connected to HomeKit I can not see them in HomeAssistant. Looks to me like a one way route. What I would like to have is the possibility to add devices from HomeKit to HomeAssistant, then delete them from HomeKit and still have them accessible in HomeAssistant and later on HomeKit

2 Likes

I’m in the same situation- anyone found a solution?

Same issue here and well explained from @LKSkywalker85 … hope there will be a solution soon :pray:

Shift your paradigm. Pair the HomeKit device with HA. Then use HomeKit bridge to share it to HomeKit through HASS Bridge.

Everyone who has commented so far is trying to add a device directly to Home Assistant first. I’m trying to do the same. We’re trying to work in the new paradigm.
I go to Add Integration, choose Apple, choose HomeKit device, and instead of being offered an ability to scan or even type a HomeKit code the only option given is a drop down of HomeKit devices already on my network (I removed several of those while preparing to add them to HA instead of HK).
Adding a Bridge tries to connect my HA Bridge to HomeKit. I just want to add a dang HomeKit device. Whatever the solution is, it’s not obvious.

I too am having the same issue. Paired the HK devices with HA, then tried to use the bridge to share it to HK. All I get in my integrations are HASS bridges for domains.

I think I am understanding the documentation correctly for setting up a Bluetooth HomeKit device. And it appears that I would need to use an ESP device as a Bluetooth proxy to get my Aqara smart lock connected to home assistant? Why? My phone has Bluetooth and the Home Assistant app. Surely there is a way to integrate this functionality.