How to get Ikea shortcut buttons to work with HomeKit

Question: how to use Ikea buttons in HomeKit?

Hi! I am new to Home Assistant. Great system! My plan is to get rid of all the different hubs and gateways and have my Home Assistant instance control all of my smart home devices (or at least the Zigbee ones to start with).

I have installed HA on a Beelink BT3 Pro Intel Atom mini PC and have purchased the Home Assistant SkyConnect Zigbee dongle. All seems to be working fine. I have successfully added a Hue light bulb through ZHA and have also paired two Ikea shortcut buttons (Somrig and Rodret).

Switching off the Hue bulb using the Ikea buttons works, with the help of these two blueprints:

  • IKEA Somrig remote E2213 ZHA](/t/ikea-somrig-remote-e2213-zha/668671
  • IKEA RODRET Dimmer Remote (E2201) - ZHA/Z2M - Control anything
    Works like a charm!

Now, here’s my question: I want to have those Ikea buttons control Apple HomeKit. The reason is that I want to use the buttons to trigger Apple Home scenes and shortcuts.

Now, the HomeKit integration (HomeKit Bridge - Home Assistant) works fine. I can get the buttons and other devices to appear in Home using either the bridge-function or as separate accessories. The problem is, they show up like this:

Scherm­afbeelding 2024-02-28 om 22.32.14

So I can not configure any tasks. Both HA and HomeKit are responding to both the physical buttons as when I click the ‘virtual’ buttons in the Apple Home app to switch them ‘on’. Events are fired in all cases.

It seems as though it triggers the ‘identify’ event. Also, when I include automations in the HomeKit bridge integration, the buttons are shown in Apple Home as automations. Clicking the ‘virtual’ buttons in Apple Home then enables or disables the automation in HA.

Hopefully my explanation is clear. I wanted to add more pictures and links but unfortunally as a new user I cannot. :frowning:

I hope that someone can shed some light on (pun intended :slight_smile:) this. Would be great to get it to work. Thanks in advance for all thoughts or advice.

Alright, this is solved. For future reference: I needed to enable Advanced Mode for my profile. I then got an extra ’Advanced configuration’ page, where I could include devices which should show triggers in HomeKit.