How to get SV3C WIFI camera to work with Home Assistant

These instructions assume that your camera is connected via WIFI to your network and is on during testing.

STEP 1: Activate ONVIF in the APP
To start, go into your app and activate ONVIF. Go to Settings > Onvif Settings
Activate it so that it is on. Below that, the app provides you with the IP address, username and provides a space to enter a password. Create a unique password that will use to log in to the RTSP video stream.

STEP 2: Identify the RTSP port
For the next step, I had to download use ZenMap to figure out that RTSP is on port 8554 and HTTP is on port 8000. I haven’t used http for anything but it was a starting point for information. This is likely a default for all the SV3C cameras but I can’t promise that. SKIP this step and if the following steps don’t work, then return here and download Zenmap. You will only have to run 1 command:

nmap -p 1-65535 [ipaddress]

Where [ipaddress] is the 192.168.x.x for your camera. The resulting RTSP port info is what you need.

STEP 3: Create the URL for VLC to Verify RTSP Stream Works
The next step was completely fortuitous. I was rummaging different sites and racking my brain trying to decipher how to get access to the RTSP since I knew where it was located. I stumbled across this site that basically tells you how to construct the URL with the specific PATH for your SV3C device. The link is: https://www.ispyconnect.com/camera/sv3c

Generally speaking, the RTSP should like:
rtsp://username:password@ipaddress:port/PathFromURL

Mine looks like:
rtsp://admin:[email protected]:8554/Streaming/Channels/101

Copy and paste that link into VLC player “Open Network Stream…” box and hit enter. It should work as long as your camera is connected to your network. If not, check your username, password, PORT number and PATH. Verify that you are using a COLON and not a period to separate the username and password as well as the IP and the PORT number.

SIDEBAR: This link may be helpful for those looking to use non-SV3C hardware: https://www.makeuseof.com/how-to-control-cctv-camera-home-assistant/

STEP 4: Add Integration to Home Assistant
Open Home Asssistant. Under Settings, select Add Integration.

  1. Enter “Generic Camera”.

  2. Leave the “Still Image” COMPLETELY BLANK. I was racking my brain trying to configure this initially, but ENTER NOTHING or you will get an error at the end when you try to submit.

  3. In the “Stream Source” box enter the same RTSP w/o the USERNAME and w/o the password. For me, this looks like:
    rtsp://192.168.0.99:8554/Streaming/Channels/101

  4. Under RTSP transport protocol, select “TCP” (this was info that I obtained from Zenmap. If you have issues, consider using Zenmap to determine the protocol. I did not have to do this but just a general debugging suggestion if you run into issues.)

  5. Under Authentication, select “basic”.

  6. Under Username and Password, enter the appropriate details that were removed the RTSP URL in the prior step.

  7. Select “SUBMIT”

  8. When the window prompt appears asking if the image looks good, click YES and hit submit EVEN IF YOU SEE A BROKEN IMAGE!! Trust me. It takes 30-60 seconds to import the stream. It’s not instantaneous.

That’s it. You should be able to add the entity to your dashboard. Give it like 30 seconds to reload and import the image from your RTSP stream even when you click on the “Generic Camera”. yes, annoying that it isn’t super duper instantaneous but it works.

If anyone else figures out how to obtain the other attributes on the camera such as the storage or motion detector sensing, then please let me know!

2 Likes