How to get the Green Bar to show?


I feel like I’ve tried everything. Can someone please help me connect this darn device? I’ve read so many articles and watched so many videos. It seems to get brushed over since it’s so easy to do, but that’s not the case for me.


  name: esp32
  platform: ESP32
  board: esp32doit-devkit-v1
  # board: nodemcu-32s

# Enable logging

# Enable Home Assistant API

  password: "3e8d2b36cd118a1f6ee0f330cb5d5c6e"

  ssid: "...searching"
  password: "blahblah"
    # Set this to the IP of the ESP
    # Set this to the IP address of the router. Often ends with .1
    # The subnet of the network. works for most home networks.

  # Enable fallback hotspot (captive portal) in case wifi connection fails
    ssid: "32 Fallback Hotspot"
    password: "f7MMIYgh3LoF"


Maybe start by posting your YAML, correctly formatted as per

First, the use_address under the Wifi section is only if you need to change the IP address while updating over OTA. If you want to set a specific IP address, use manual_ip. See here.

If the header isn’t getting green after a while, try to refresh the page (the ESPHome dashboard). If this doesn’t work, you can try to configure ESPHome to use status_use_ping. This changes the way ESPHome looks for your devices (nodes). After a restart of ESPHome it should get green. :slight_smile:

EDIT: Or is it still the “same problem” as in your other thread?

I changed it to use manual_ip but it’s still not working. Not sure if I chose the correct board in the yaml. Everything seemed to flash ok and I can ping it, but I don’t know if that means the board I picked was ok.

Do you have a link for where you purchased the board?

Do you have a link for where you purchased the board?

You have the correct board type.

Nice, and thanks for the help. Any ideas on why it doesn’t connect?

How are you flashing the config to the device?

Which software serial tool?

I’m manually downloading the .bin file and then using ESPHome-Flasher-1.3.0-Windows-x64, since I’m not able to use any other method.

That’s good. I’ve read that the esphome flasher has some extra goodies required in the bootloader.

Try changing your filename to the same as your device name (esp32.yaml rather than 32.yaml). Then flash it again.

Updated the name. Still doesn’t connect.


After you flash the device with the esphome flashing tool what does the on screen log in that tool say?

Using 'COM3' as serial port.
Writing at 0x00088000... (100 %)Wrote 886048 bytes (505886 compressed) at 0x00010000 in 13.3 seconds (effective 533.8 kbit/s)...
Hash of data verified.

Hard Resetting...
Done! Flashing is complete!

[22:37:22][I][logger:170]: Log initialized
[22:37:22][C][ota:366]: There have been 0 suspected unsuccessful boot attempts.
[22:37:22][I][app:029]: Running through setup()...
[22:37:22][C][wifi:037]: Setting up WiFi...
[22:37:22][D][wifi:365]: Starting scan...
[22:37:24][D][wifi:380]: Found networks:
[22:37:24][I][wifi:426]: - '...searching' (44:07:0B:0F:DE:C4) ▂▄▆█
[22:37:24][D][wifi:427]:     Channel: 1
[22:37:24][D][wifi:428]:     RSSI: -33 dB
[22:37:25][D][wifi:430]: - 'Cisco62242' (58:6D:8F:73:60:D4) ▂▄▆█
[22:37:25][D][wifi:430]: - 'MySpectrumWiFib6-2G' (B8:D9:4D:2E:1D:BC) ▂▄▆█
[22:37:25][D][wifi:430]: - 'SpectrumSetup-E9' (76:69:42:9C:FF:E7) ▂▄▆█
[22:37:26][D][wifi:430]: - 'ATT7Wpz343' (D4:B2:7A:EB:C3:E1) ▂▄▆█
[22:37:26][D][wifi:430]: - '' (0A:84:9D:77:A9:C4) ▂▄▆█
[22:37:27][D][wifi:430]: - 'AnyCast-BFA76C12' (D2:C0:BF:A7:6C:12) ▂▄▆█
[22:37:27][D][wifi:430]: - 'DIRECT-6E-HP DeskJet 2600 series' (C8:D9:D2:76:CB:6F) ▂▄▆█
[22:37:27][D][wifi:430]: - '' (D4:B2:7A:EB:C3:E3) ▂▄▆█
[22:37:28][D][wifi:430]: - 'diagonalley' (14:59:C0:90:39:85) ▂▄▆█
[22:37:28][D][wifi:430]: - 'TC8717TC3' (08:95:2A:E6:DA:C9) ▂▄▆█
[22:37:28][I][wifi:235]: WiFi Connecting to '...searching'...
[22:37:28][I][wifi:498]: WiFi Connected!
[22:37:28][C][wifi:344]:   SSID: '...searching'
[22:37:29][C][wifi:345]:   IP Address:
[22:37:29][C][wifi:347]:   BSSID: 44:07:0B:0F:DE:C4
[22:37:29][C][wifi:348]:   Hostname: 'esp32'
[22:37:29][C][wifi:352]:   Signal strength: -34 dB ▂▄▆█
[22:37:29][C][wifi:356]:   Channel: 1
[22:37:30][C][wifi:357]:   Subnet:
[22:37:30][C][wifi:358]:   Gateway:
[22:37:30][C][wifi:359]:   DNS1:
[22:37:30][C][wifi:360]:   DNS2:
[22:37:30][D][wifi:507]: Disabling AP...
[22:37:30][C][ota:029]: Over-The-Air Updates:
[22:37:30][C][ota:030]:   Address:
[22:37:31][C][ota:032]:   Using Password.
[22:37:31][C][api:022]: Setting up Home Assistant API server...
[22:37:31][I][app:059]: setup() finished successfully!
[22:37:31][I][app:105]: ESPHome version 1.19.4 compiled on Jul  7 2021, 22:28:16
[22:37:31][C][wifi:484]: WiFi:
[22:37:32][C][wifi:344]:   SSID: '...searching'
[22:37:32][C][wifi:345]:   IP Address:
[22:37:32][C][wifi:347]:   BSSID: 44:07:0B:0F:DE:C4
[22:37:32][C][wifi:348]:   Hostname: 'esp32'
[22:37:32][C][wifi:352]:   Signal strength: -34 dB ▂▄▆█
[22:37:32][C][wifi:356]:   Channel: 1
[22:37:33][C][wifi:357]:   Subnet:
[22:37:33][C][wifi:358]:   Gateway:
[22:37:33][C][wifi:359]:   DNS1:
[22:37:33][C][wifi:360]:   DNS2:
[22:37:33][C][logger:189]: Logger:
[22:37:33][C][logger:190]:   Level: DEBUG
[22:37:33][C][logger:191]:   Log Baud Rate: 115200
[22:37:34][C][logger:192]:   Hardware UART: UART0
[22:37:34][C][captive_portal:148]: Captive Portal:
[22:37:34][C][ota:029]: Over-The-Air Updates:
[22:37:34][C][ota:030]:   Address:
[22:37:34][C][ota:032]:   Using Password.
[22:37:34][C][api:095]: API Server:
[22:37:35][C][api:096]:   Address:

Your domain name servers are not set correctly in your router.

What should it be?

Preferably what your ISP recommends. But you could also use and

I believe I changed it in the router:

It didn’t change after flashing it again though. Do I need to add anything to the yaml file?

Did you restart the router? Often a requirement when changing network setup

I did. Then I flashed the device.