How to ignore AVM Fritz!SmartHome integration

I’m currently on 2021.3.0 and I have the “Fritz!Box Tools” integration set up to monitor my internet connectivity.
Since this release, I’m getting a notification in the UI, requiring me to reconfigure the “AVM Fritz!SmartHome” integration.
It’s asking for a username/password combination that I don’t have as I’m not using any of the Fritz!Box’s SmartHome stuff.
I would like to just ignore this integration, but there is no button to tell it to go away :wink:
The integrations that are already set up at least have a “Disable” menu item - this one doesn’t even have a menu.

How do I get rid of that?


Strange, in my setup, they have been ignored by me long ago, and they stay ignored even after the last update of HA.

The login credentials, are they not just the ones printed on a label on de backside of the Fritz?

I have set an individual password to access the Web UI of the Fritz!Box, but it doesn’t require a user name (which the integration also asks for).
I just noticed that the box creates an auto-generated username fritzXXXX associated with that password.
I tried that and instead of “Invalid authentication” I’m now getting “Unknown error occured”.

I’ll think I’ll sit this one out and ignore it for now…


I just updated to 2021.3.2. After launching, I got a notification about a newly discovered “Fritz!Box 7590” device.
For configuration I put in my box’s credentials (fritzXXXX user and WebUI password) - which was accepted without any errors.
Then the SmartHome integration showed up (not requiring any configuration) and I could easily disable it like any other integrations.
Problem solved.

Thanks to whoever fixed it :+1:


Under Integrations I have 2 AVM FRITZ!SmartHome showing.

One says I need to reconfigure and it won’t accept my username/password that I log into the web interface of the Fritzbox (I don’t use SmartHome in the Fritz box).

The other has FritzBox!7590 written under the AVM FRITZ!SmartHome and is not showing any errors.

I would love to get rid of the one showing the “Reconfigure” message as I don’t know why there’s 2

In your avm go to service > fritzbox users. There you can see thet fritzXXXX username.

Use that and your web ui password.

Thank you. That worked.