How to ignore plex from discover?

I have tried for some time now to make so that Plex isn’t automatically discovered by Hass. I found out that “ignore” is the way to go, but every time I try to configure it I get an error message when I access Hass.
“Invalid config
Following components and platforms could not be set up:

Here’s the part of the config

 #Discover some devices automatically
        - plex

If I change Plex to Sonos, the error message disappear but then I can see Plex.
So how do I configure so that Plex is ignored by the discover.

I have also tried to change plex to plex_media_server. But same error message.

1 Like

I’m also having this issue. My config looks exactly the same:

    - plex

And the specific relevant error message(s) is/are:

Mar 12 07:11:25 dormouse hass[3518]: INFO:homeassistant.loader:Loaded discovery from homeassistant.components.discovery
Mar 12 07:11:25 dormouse hass[3518]: ERROR:homeassistant.config:Invalid config for [discovery]: value is not allowed @ data['discovery']['ignore'][0]. Got 'plex'. (See /home/homeassistant/.homeassistant/configuration.yaml, line 62). Please check the docs at
Mar 12 07:11:25 dormouse hass[3518]: ERROR:homeassistant.setup:Setup failed for discovery: Invalid config.

Is this a bug in 0.40? Or is the name of the platform not plex?

Spoke too soon! I figured it out. You’ll want to use the following:

    - plex_mediaserver

Dove into the source for the discovery component (homeassistant/components/ which showed plex registered under the above name in its SERVICE_HANDLERS dictionary.



Yes, that did it. Everything looks fine now.