How to install and configure eclipse mqtt docker


I’ve just installed the ring alarm system and I would like to integrate it to HA. I need to configure eclipse mqtt, but I am completely lost. Could someone please tell me a step by step about how to get this up and running and how to create/configure the yaml file?

Thank you!

Do you really mean “docker” (i.e. standalone) or do you mean add-on added thru HA Supervisor?

they are similar but not exactly the same.

I have eclipse mosquitto configured as standalone docker but I don’t use add-ons so I can only help with the first one.

Yes, that’s exactly what I’m looking for, the standalone docker. I don’t have HA supervisor, just the docker HA

Here is the docker run command I used to set it up:

sudo docker run -d --name=eclipse-mosquitto --restart=unless-stopped -p 1883:1883 -p 9001:9001 -v /home/finity/docker/mqtt/config/mosquitto.conf:/mosquitto/config/mosquitto.conf -v /home/finity/docker/mqtt/config/passwd:/mosquitto/config/passwd -v /home/finity/docker/mqtt/data:/mosquitto/data -v /home/finity/docker/mqtt/log:/mosquitto/log -e PGID=1000 -e PUID=1000 -e UMASK_SET=000 eclipse-mosquitto

first create the desired volume to store the config files and change the locations for those in the command above.

You can download the default mosquitto.conf file from:

and edit as necessary. Change the persistence info and logging.

Then enter the shell of the container by:

$ sudo docker exec -it eclipse-mosquitto sh

Create a username and password:

/ # mosquitto_passwd -c /mosquitto/config/passwd/pwfile

Once it goes to the next line just type in the password (there won’t be a prompt until after you hit enter)

Re-enter password

It’s possible some things have changed since I originally set it up a couple of years ago.

1 Like

Thanks for the instructions. I get up to the last point and now I’m stuck again. Any Idea?

/ # mosquitto_passwd -c /mosquitto/config/passwd/pwfile astra
Reenter password: 
Error: Unable to open file /mosquitto/config/passwd/pwfile for writing. No such file or directory.

What is the directory structure of the mounted config volume?

I just tried to spin up a new container for testing using my run command above and I was getting a few (let’s just call them…) “anomalies”.

Here is the one that ended up working:

sudo docker run -d --name=eclipse-mosquitto-2 --restart=unless-stopped -p 1885:1883 -p 9004:9001 -v /home/finity/docker/eclipse/config:/mosquitto/config -v /home/finity/docker/eclipse/data:/mosquitto/data -v /home/finity/docker/eclipse/log:/mosquitto/log -e PGID=1000 -e PUID=1000 -e UMASK_SET=000 eclipse-mosquitto

(had to change the ports around a bit)

then going into the container I ran the following and it worked:

mosquitto_passwd -c /mosquitto/config/pwfile <username>

I’m still not sure why the first one wouldn’t work. I’m pretty positive that’s the one I used when I initially set it up. I have a log of all the current commands I used and I took it directly out of there.

But like I said things may have changed since then…