How to install conbee on Synology NAS

Hi,

I have a 718+ Synology NAS and I am trying to get the conbee stick working.

  • I put the conbee stick in the USB port of the NAS.
  • Installed the Deconz container in Docker

But now I am completely stuck. What should I do next? I tried adding Deconz in HA via integrations. But it says it cannot find an API key.

Thanks!

1 Like

I just got my Conbee stick working on DS918+ in docker.
Which container do you use ? I use “marthoc/deconz”

I had to SSH to the nas and run 2 commands to load the drivers for the Conbee:

sudo insmod /lib/modules/usbserial.ko
sudo insmod /lib/modules/ftdi_sio.ko

Then you should be able to find the usb under /dev/ttyUSB0
then you need to run the docker container with “high privilege” as Synology docker does not support the “–device” command.

Thank you for the hints, this worked for me on my DS218+. I can find the conbee and can trigger lamps etc. My problem is, that /dev/ttyUSB0 cannot be found after a restart of the diskstation. It works again, when I have connected via SSH and called the two commands above (usbserial.ko and ftdi_sio.ko). How can I set it up, that the conbee is found everytime on a startup of the diskstation, that I don’t have to load the drivers for Conbee everytime?

I found a possibility do this during a startup script from

1 Like