How to install HA on a NUC?

Hi, I am now seriously thinking of migrating from Homeseer to HA and I am somewhat confused about how to install HA. I think I’m going to get a NUC.

My Homeseer system consists of ~10 programmable controllers (made by Ouman in Finland) which have Modbus RTU interface. Each of them is connected to a Moxa tcp/ip-rs485 converter. In addition to this, I have Steca inverter and two Mitsubishi air pumps, all these with Modbus RTU interface. So, my main concern is how to integrate them to HA. Of course I have loooked at the HA Modbus integration. I have now installed HA on a Oracle VirtualBox but soon I realised that VirtualBox supports only 4 serial ports so this is not a suitable way of installation method for me. I have one extra Ouman controller for testing purposes. I have managed to get Modbus working but I seem to get quite frequently error messages in the log:

2021-12-26 09:10:44 ERROR (SyncWorker_4) [homeassistant.components.modbus.modbus] Pymodbus: Ouman EH686 autotalli: Modbus Error: [Input/Output] No Response received from the remote unit/Unable to decode response

I’m using Serial Port Monitor to sniff the serial port traffic. It seems that I’ll get correct response as a HEX code from the serial port but every now and then the response is empty. I have been playing around with delay, timeout, retry_on_empty and message_wait_milliseconds parameters but still no luck. I have managed to get the Modbus traffic in HS working flawlessly.

So, now when Modbus is the most critical integration for me I’m wondering which installation method would give the best outcome. Should I install HA supervised on Debian? Somehow I hesitate to install on a VM (like Proxmox) due to these timing issues with Modbus. On the other hand, I read from some post that you aren’t supposed to install any additional software in Debian, and if you do and face an issue, you will only be able to rely on community support.

Any thoughts?

Edit: Forgot to mention that I may want to integrate my three Hikvision cameras so HA OS installation is not an option either.

i’m not familiar with any of the IO hardware you use but if you are getting a more powerful machine (NUC) to run HA on you will most likely also use it for other things outside of HA. Otherwise it’s a waste of resources since HA itself uses almost none.

So the only real option if a VM isn’t working is to install HA Container which uses Docker that you must install yourself. It’s the version I run myself.

you could run a straight HA Core install but NOBODY does that. :laughing:

installing HA Supervised and using any other app on the machine will give you an unsupported installation. Which isn’t as ominous as it sounds tho. everything still works but you can’t get any “official” support directly from the devs. But I’ve been using HA for 4 years and have never gotten any official support directly from any devs either. The forums are my go to source for help and we usually don’t care what version you are running. we are still willing to help if we can.

Thanks. I forgot to mention that I already have one add-on (Studio Code Server) installed so if you install HA Container is it so that add-ons are not supported. I’m somewhat confused.

Yes, add-ons are not supported in HA Container. they are only available in a supervised-type install (HA Supervised or HA OS).

But you can install anything that you can as an add-on in a regular docker container with no need for add-ons.

OK, thanks for clarifications. NUC now ordered.

1 Like

I followed this YouTube guide, very helpful. Migrate from a Raspberry Pi to a Virtual Machine (Windows). Step by Step. - YouTube