How to install owserver? 1-wire and Home Assistant OS

Dear Community Members,

I just set up home assistant on my Raspberry Pi 4 (Home Assistant OS) and am quite happy using a 1-wire temperature sensor. It‘s a DS18B20 on GPIO 4 and it works fine using sysbus.

Since sysbus will not be supported any more (architectural design decision, https://github.com/home-assistant/architecture/blob/4d66082eab81d5f4740e0d86333f9135a90e6aad/adr/0019-GPIO.md) I‘ll have to change to owfs. But what do I have to do to install owfs/owserver on my Raspberry Pi?

When I SSH to the machine I can‘t access any packet managers (e.g. yum, pacman, apt-get —> command not found). And since Home Assistant OS uses docker containers all manual changes might get lost during the next update.

I would be so glad if anyone had a hint.

same boat everything says to install “owserver” but no damn guides to do it

you would at least think they would have it in the software package for installation …
not even HACS lists it has to be manually added

1 Like

Did anyone try this one?
I have an USB adapter, not using GPIO, not sure if it would work

1 Like

Dear Members,
Need to bump this thread.

I’m tryiging to fire up 1-Wire and owserver with no luck.
Owserver looks installed as in:
Appears in sidebar “owserver /1-wire)” (link http://xxx.yyy:8123/9e0ef242_owserver/dashboard says “502: Bad gateway”
Appears in integration supervisor as a service and entity.
Possible to open page for the service. It says that the service is running.

But 1-wire integration will not find the host :“9e0ef242-owserver” (mandatory for the 1-wire integration).
I cannot understand how to find any traces of the owserver install. No folders or files that relates to this.
Command “netstat” in terminal will not reveal an open port 4404 for ows

How to proceed?
I see more members struggling with this but no solutions has been shared.

Home Assistant 2022.8.6
RPi3 (32bit)
1-wire usb dongle ds9490r

Found a W1 folder but no sensor data:

Found the logfile for OWSERVER(1-wire). Says something is missing.


Looking for a possibility to install from terminal, but make and sudo commands are not available.

Wasn’t worth the trouble for me. I found it simpler to get a cheap wemo, use an old usb micro power supply and connect my sensors from there. Super easy with ESPHome.
There a other esp boards that don’t require soldering

Thank you for the tip. I have ESPHome installed. Might give it a try. Does it work as good with GPIO from ESP as with the 1-wire adapter? Got some complex 1-wire net with 20+ temp sensors that I hope to monitor i HA. It has worked flawless with the adapter to a windows PC with SwitchKing, but it seems quite obselete and difficult to include in the HA-setup.

damn, so I guess this answer to my question :frowning:

I have four ds18b20 with about 2m/6ft of cable each to monitor the hvac. They’re polled every 30 sec with no hint of an issue. So not as extensive as yours, there’s probably more an issue with powering all of these than running out of bandwidth anyways.
ESPHome — ESPHome

I gave up OWFS and wired up an esp8266 instead. Unfortunately, the retired USBds9490r handled the whole 1w net with no problem. Net is four arms 20+ meters with 5-10 ds18b20 each. Breaking every rule for recommended design, but it worked fine. The esp8266 with GPIO polling will only handle one arm, so I guess it will be four esp8266 boards.

Installed 2 ESP8266 borads to share the 1w networks. Power the 1w line from 5V and use ~3kohm pull up. Works perfect.
Current 14 sensors to ESP1 and 6 sensors to ESP 2.

Owserver is uninstalled. It’s never too late to give up :slight_smile:

1 Like

sorry but this is ridiculous!

I understand the incentive to not use GPIO, even Microchip (formerly Dallas) discourage that.
But many of us is using some kind of propper 1-wire bus connector (like DS9490) which is MUCH better than the bit banging done with GPIO and ESPHome.

I suggest the propper way to handle this is to use a add-on with the owserver in it, and then use the official 1-wire integration to connect to that add-on.

For me personally right now, I guess the solution will be to put the owserver on another virtual server, and use the 1-wire integration to connect to that one. But I would have preferred to keep it all on the same VM.