How to make the vacation weather follow you on your trip, with Home Assistant!

While on vacation, we tend to plan our activities around the weather, so that we don’t have to “enjoy” a surprise shower or snowfall. For this purpose there exist a myriad of free phone apps you can install — with the caveat that these apps often show intrusive ads, sell your private data, and track your whereabouts. They also don’t allow you to conveniently check the weather in the past, because they don’t save weather records locally.

What if preparing for vacation didn’t have to be this way?

What if you could have your own Home Assistant move a “vacation spot” around with you, so up-to-date weather follows you when appropriate wherever you go on vacation?

It turns out you can. And here’s how you do it, step by step.

Check out the complete guide at:

4 Likes

thanks for this as the question pops-up a lot.
I however can not use this as I have mutliple people in different locations so my solution is to use a weather integration that accepts lat/lon (from the device tracker), e.g. openweather and separate dashboard per person. This does not solve TZ challenges with other func though :slight_smile:

Yes, my post assumes you go alone on vacay or with your partner to roughly the same place with 5KM radius.

Yep and I do love your extensive user-friendly explanation, the techy stuff is quite frequently off-putting for a lot of people

1 Like

If you use the companion app there is a current tz sensor that can be enabled. You can use that to change the time based on your phones location.

Oh! Useful to know! Thanks. Although time zone should not matter for daily forecast, but if it does, I need to know so I can update my methods.

Thanks and never tried this before (as I am not changing TZ often). When I added openweather for ‘me’ (travelling) in the past, it worked fine for the location but not for the time of day… will try to do a forced tz change later this week

Off topic to your exact questionbut I have pihole running at home. I’m using tail scale to access my local network for home assistant remotely.

Edit - I totally misread this post. My bad! Very nice configuration, and thanks for sharing! Continued…

DNS is configured in tail scale to point to my pihole.

Result is that most ads from those apps get filtered and don’t even show up whether I am at home or not. I have a couple weather apps like you mentioned that plain just don’t load the ads.

My brother was visiting recently and commented that normally he quits playing video games on his phone because of the annoying ads, but connected to my network he didn’t have that issue. (For better or worse :joy::person_facepalming:)

Not bad, but the app manufacturers still collect and send that data from your phone back home.

Definitely still a risk, depending on how they are doing that. If they’re using third party analytics, maybe they’re caught in PiHole’s list, but it’s not a guarantee.

I suppose in any case they’re getting the location details of the forecast request.

I like you’re solution, it’s definitely better.

1 Like

@Rudd-O I am stuck on the automation configuration , can’t seem to figure out the change required to complete the automation, the service “homeassistant.disable_config_entry” doesn’t seem to be available.

        sequence:
          - service: homeassistant.enable_config_entry
            data:
              config_entry_id: 8424bdd6a7a8f346286327768bdaa75d
      - conditions:
          - condition: trigger
            id:
              - vacation-disabled
        sequence:
          - service: homeassistant.disable_config_entry
            data:
              config_entry_id: 8424bdd6a7a8f346286327768bdaa75d

image

Nice solution. Something to be aware of: There is a catch,. If your zone moves to your actual home location, people might be registered to that location instead of zone.home. That might break some automations. You may need to do something the vacation zone is never set close to home.