How to map a NAS network drive?

I’m trying to mount a samba share on my Synology NAS to be used as a backup target.
I’m not able to do that, I’ve tried the following:

  • Mounting on commandline ->succesfull, but of course, lost on restart of system)
  • Adding to fstab -> gets lost / overwritten on restart
  • Mounting in shell script and calling that from within HA with the shell-integration -> does not work, I do not understand why this did not work (possibly ‘strange-characters’ issue)
  • Mounting by putting the mount command directly in shell-integration in configuration.yaml. I started of having issues with ‘strange-characters’ in my password. When I changed that it reported the

This is the command I use (change IP, username, password):
mount -t cifs // NetBackup -o username=name,pass=password,vers=3.0

I tried replace the NetBackup target with (./NetBackup config/NetBackup and the full path in config folder and in the share folder.

Also tried this after successfully creating a folder in the config dir using a shell command.

I keep getting the message:
mounting // on NetBackup failed: Resource busy

Anybody experience in this? How to solve this?

Tips for shell_command and syncing snapshots to windows network share

If you want something that does this for you automatically (and more, like managing the number of backups kept locally and remotely) and you are running HassOS there’s this addon:

Thanks alot! did not know this existed, first test seems promising. I got my first backup on my NAS (as well as on the machine I’m running HA on.
Solved and happy!

1 Like