How to mount USB stick to HA

Hi, I am trying since days to mount a USB stick to my HA, running on a PI4. I have the simple OS installtion, so no docker. When I try to mount the drive, I got message “permission denied”. So no way to mount the stick. I am sure, I am not the first one with this problem, but if not yet found a proper solution here in ithe forum. Could anybody help in this? Thank you!

How do you attempt to mount it? This is actually a Linux question, not HA related.

Apologize for maybe using wrong tread, but as I am using the terminal modus from HA I though would be here the correct place to put in my question.

Ia am using the terminal modus and typing: mount /dev/sda1 /media/usb-driver/

directory usb-driver has been made before already and is available.

So you use Home Assistant Core in a Python vEnv? Because every other installation type is using Docker …

yes think so, I just used the image, flashed this on a SD card and that was it. So not so much involved in the correct name/env.

So, this makes you another novice user of Home Assistant OS (using Docker) and terminates my ability to help, as I don’t use that installation type. Maybe others can.

May I ask what you want to achieve here? As the level of integration depends on your task. If you plug the USB stick into your device, it will automatically be mounted. With the SSH addon you can check this out, but I guess that is not what you want.

OK, reason is, I want to save some of the yaml files on that USB, done with an automation afterwards. I know there are backup options, but I really want here just copy the yaml files and the *.db file on that stick. That’s all.
Any help/idea how to do?

Okay, for me this sound like the SSH addon is all you need. Have you tried that? And then looked with mount if and where devices are mounted?

1 Like

Do you have a tab called ‘Supervisor’ in the left hand side panel?

If yes to my previous question, install the Samba add-on

Yes, Samba is installed, works as it should, get direct access to the SD card.

Unfortunately I could not mount anything, as written above. For sure get manually access to the SD card with Samba, but I want to have an extra USB stick mounted. Any idea to do so?

It’s not natively possible to do that. Thats why I suggested the Samba add-on so you can simply transfer files using another PC.

There is a work-around of sorts being used here. I haven’t tried it