How to move ESPHOME configuration from one server (RPI) to another (Ubuntu-Hassio)?

I had Esphome with a couple wemos working on a Raspberry pi, HA installed on docker (no Hassio). I installed Esphome thru command line.
Now i moved all to an IntelNuc with Ubuntu, and installed Hassio (alternative install, on Docker). On HA i can see the Esphome old entities after adding the as integrations.
But at the Esphome Dashboard (as Hassio addon) i see the default start page, without my wenos. How can i add them there so i can edit the configuration of each wemo? Should i start from scratch or is there a way to import them.


1 Like

@mcarty The only thing you really need to backup is the YAML files. I would stop wasting any time on finding a easier method and just copy and paste them in your favorite text editor.

Ok, but how do I edit/backup them now if my esphome dashboard is empty?

copy the yaml file that you have on the pi3, then on the HASSIO/ESPhome, you click + and add a new node (no matter what you write with the wizard, you will overwrite it later), then when you are in HASSIO/ESPhome with the yaml editor, cancel everything and copy/paste the content you have/had in the pi3.
Don’t forget to click SAVE, that’s it


Exactly like this. It is as easy as it sounds.

I also had this problem, partially solved by the above instructions.

After you pasted and saved the device ESPhome YAML config on the destination server, on the new server the config shows “404” until the device is still connected with the old server.

So, after deleting the device on the old server, it will connect as the just configured one on the new server, and you will see it on the “new” ESPhome dash.



Did someone try using the Hassio snapshots?
I believe it should work otherwise there’s something wrong

Edit. I see op is not migrating from a Hassio

I just moved my Hassio from RPi to VirtualBox. I created a snapshot in the Pi, moved it with Samba and restored in Virtualbox. All my ESPHome entities were there and working with no additional need to config.

1 Like

I did a fresh install of Hassio and tried to do a partial restore when I chose only to restore ESPhome. The addon was installed but none of the yaml configs from my esphome devices show up. I tried to copy them over manually using samba folders but esphome does not pick them up either.


It should work, you have to refresh the ESPHOME page again (try emptying cache etc).


  • Make a backup of you configs. Store them somewhere safe.
  • Uninstall ESPHome Addon
  • Reboot Hassio
  • Install the ESPHome Addon
  • Start the ESPHome Addon
  • Copy back the files you have backed up. (For example couch.yaml see image below)


  • Then, enjoy :smiley:

Yes, I tried with snapshots and its working. Other wise 2nd method is to copy entire esphome folder from HA and then after re-install simply copy this folder back to the folder where esphome is installed.