How to proceed from here - VM

I had been running Hassio on RPi 3B+. I’m not very technical and as advertised, this configuration was a great way for my to get into the smarthome game.
Since finding HA and all you guys last August, my home had come a long way. I have 3 different manufacturers’ robot vacuums, Ring doorbell pro, 4 Nest Smoke alarms, 12 TP link switches ,4 Wemos, 2 Kuna cameras, my garages via Gogogate, my Ring Alarm system, a Volvo, my Google wifi stats, my Samsung smart fridge, my hydrawise sprinklers, my Roku, and intermittently the Xbox. I’m sure I missed some, but you get it. Also, I had remote access with Duck DNS, as well as Tor for emergencies (it’s so slow).
Halfway through this journey, once I fried a Pi, got a new one, and popped in the SD card, and was back in business. But last week, everything went Fubar after a back up and upgrade. Long story short l, the Pi works but the card is corrupted. Fortunately, reading this forum I found a recovery software and could find my recovery tar files as well as my config file! (Yes, I know, now I should backup to Google drive. On my to do list.)
I got a new card and went about installing a new Hassio image so I could reload my last backup on the Pi. I dropped the new image once I got Samba up and running, went to load it, and Bam! Dead in the water (the backup is bad!)
So, I thought screw this, I saw Rob’s video (from the Smarthomehookup YouTube channel on installing Hassio on a virtual machine. I have an old laptop I can use.
I followed his guide. Problem #1: his commands to reserve a certain IP address didnt work for me (I am using the VM on Windows 7). Problem #2, my Google wifi only recognizes the host laptop’s IP address, but none of the virtual machine. Now when I run Fing, I am able to find the IP of the Hassio in order to log into the front end (my router has never allowed the hassio.local:8123 thing).
So now I have HA running (loaded my second newest backup and worked fine, as the latest backup was corrupt), albeit on a different IP address. But my VM isnt visible on the router, so I cant get up my Duck DNS and port forwarding. Tor does work, but again, too slow.
The port forwarding button isnt able to be activated on the VM ware options.
I really like the speed of this old laptop over the Pi, but I dont know how to get DuckDNS and my NGinX running if I cant forward 443 to 443.
I guess I can save this snapshot, then restart everything back on a Pi, and load up everything onto the Pi, but it is slow, and despite using another Samsung EVO SD card, I’m afraid it will fry again.
Finally to my question: given my limited technical skills, what is best for me? Back to a slow Pi? Is there a way to get my Windows 7 laptop running the VM Ware to be recognized by my Google Wifi? (Already tried unplugging the wifi and router and restarting, didnt work.) Do I need to look into a NUC or a Lenovo m73 for speed?
This Home Assistant software is evolving so quickly which is so exciting, but it also makes for documentation to be inaccurate rather quickly!
I appreciate your thoughts and advice on how to proceed.

What command did you use? The exact commands.

Are you running in Bridge mode on the VM?

HUH? You don’t port forward anything in the VM, or on the Host…Are you using VMWare or Virtualbox? The video very plainly uses Virtualbox.

In your router, you just forward the port to the IP of the device. Why do you need to “see the IP in the router” for that to happen? Can’t you just manually type in an IP address like, pretty much every router in the world lets you do?

You realize that a NUC doesn’t change anything here? You have a computer that will run HA just fine. Are you stuck on Windows on it?

First off, thanks for taking the time to respond and help me out.

  1. The commands from the video are as follows:
nmcli con edit "HassOS default"
print ipv4
set ipv4.addresses [hassio ip address]/24
set ipv4.dns [router ip address]
set ipv4.gateway [router ip address]

But the initial nmcli con edit “HassOS default” produced an error, and I stopped there.

  1. Yes, I am running bridge mode for the VM.
  2. I’m using teh Oracle virtual box, as in the video. Sorry for if my terminology is inaccurate. I understand how it is important to say things correctly. These things are all new to me.
  3. Regarding how to forward the port to the device…on my Google Wifi, under the port management section, the only way (at least that I can find) to forward a port is by selecting a device listed, and then doing the port forwarding. Since the VM isn’t listed, I’m stuck. Now interestingly, under the DHCP IP reservations section above the port forwarding section, I AM able to see the MAC address of the virtual machine, and under this section, reserve the IP address via the router at the where it resides. But despite me seeing the virtual box there, there isn’t an option to forward the port in that menu (and it doesn’t show up in the other place). I can not just manually type in an IP address (to my knowledge) like every router lets you do to forward the port.
  4. I kind of figured if I can’t get things running on the Windows 7 laptop, I would have the same issues on anything else that isn’t a Pi. I’d prefer to keep Windows on it, for my kid to use.

So, while it may not have meant anything to YOU, you need to understand that error messages generally contain valuable information to those trying to help you. Saying it ‘produced an error’ without the actual error message is like going to the mechanic with your car and saying ‘It doesn’t work. Some light came on’.

figuring out this error and if it’s a syntax issue or not is the first step to resolving the problem.

Excellent point. When I’m home on my machine I’ll retry this and copy what it says. Thanks!

I must have typed everything wrong, because today with careful fidelity I was able to manually set the virtualbox IP address using the nmcli commands. I set it to (the previous address of my old Pi / easy to remember). Here’s a snapshot:

Please let me know if anything looks incorrect.
So, I saved the config and shut down the virtual box and restarted it.
Now, not only does the new IP NOT display my front end (wont connect) but the old one won’t either!
Again, the Hassio instance isn’t seen on my Google Wifi. It DOES show up on my Fing app, which states it is associated with 2 IP addresses: the new one I just set, as well as the one for the laptop it is running on (
I am NOT able to ping hassio, however.
Not really sure how to rescue my setup.
Other than me screwing it up tonight by assigning an IP address manually, I think this is mostly a Google Router issue.
I think I found a similar situation in their help forum:
Any guidance as to how to “find” my Home Assistant, both in terms of now finding the front end, and then ultimately figuring out port forwarding.
In the virtual box I’m using the bridged adapter, with promiscuous mode to allow all.

I there some reason you set a dns nameserver to itself?

Is your third octet in your network really 86? Seems like the video was using 86 also…

It’s a laptop. It has an OS. Start troubleshooting.

Ping your gateway from the laptop.
Ping from the laptop.
Ping the IP of the HA from the laptop
Traceroute to Google
Is your laptop connecting?
Is the firewall turned on?

Based on the thread you linked, where is your router? They appear to have a double Nat setup…a router + Google WiFi. What’s your layout?

old thread I appreciate, but I ran into similar problems, have on ras pi4, wanted to move to a windows laptop i have always running as its monitor failed but other wise good laptop and use it for running blueiris that is windows only. So i installed virtual box and got it all setup ready, but, I use google wifi like the poster, and it seems you cant port forward from google wifi to virtualbox as it seems google wifi uses the mac address for routing not the IP address, so when you go to the google wifi app to configure your port forwards you only get devices listed, which is always the host not the virtualbox, when you first start the virtualbox, you might get a blip in google wifi where the VB shows for a few seconds but then gets merged into the host, because when you click on the host in google wifi it will sometimes show the host ip and sometimes the VB IP, I could find noway around this.

Has anyone else found a way to have VB on a windows 10 machine with google wifi running their network?



The anwser : My journey to configure SSL for HA OS under VirtualBox with Google WiFi

1 Like