How to properly disable unwanted Z-Wave Entities

Seems most every Z-Wave device adds multiple sensors of which only a couple are worthwhile. So I’d like to remove them from Home Assistant, so they don’t appear anywhere. But what’s the proper way to do this?

There’s a checkbox on the Z-Wave Node Management section “Exclude this entity from Home Assistant” but that doesn’t appear to do anything, as far as I can tell.

I was happy to see the new “Enable Entity” option in the Entity Registry, and I’ve used that. That works, but causes a ton of extra messages like this in the log:

Entity is incorrectly being triggered for updates while it is disabled. This is a bug in the zwave integration.

For the UI settings to apply, you need to set the device_config key in configuration.yaml, (see the docs).

  device_config: !include zwave_device_config.yaml
1 Like

That said, with the new ability to disable the entities in the Entity Registry, I don’t know if there is a reason to have both options (what’s the difference?). As the error message says, the zwave component probably needs to be updated to support handle disabled entities.

Thanks, that did it. I had used the Integration on the UI which I guess does not add that. Moved my setting to yaml and it works now.

Seems the main difference right now is one bloats your log. :slight_smile:

The new disable also removes the entity from the ZWave configuration screen, which I like less. I’d rather them be there in case I ever want to turn one back on.

Anyway, thanks for the help.

Actually scratch that. The old way also removes them from the ZWave after your next restart. So no difference there.

Out of curiosity, why not just ignore them and not place them on any view in the Lovelace UI? That way they just sit there in the unused entities section. That’s what I do with all the extra zwave entities that I don’t care to see.

It’s a lot of extra enities to scroll through…I think I had something like 50 for the dozen or so zwave devices I have. Also, I’m hoping that removing them means Home Assistant doesn’t track or update them at all, which would save on CPU.

I saw them also popping up in my logs as warnings and I agree with you, There will be a lot of z-wave entities to scroll through. Hope there will be a solution when updating HA and the new Open z-wave version (1.6).