How to reboot HA server?

Hello, I am using HA version 2023.5.2. Can someone tell me where to find the menu to reboot the server?

I remember there used to be 3 dot under Settings → System. but they are not longer there.

Press the on/off icon in the top right corner and select the advanced options. There you will get an additional option for rebooting the system.


Thanks for the response. I have spent an half hour to look around but cannot find anything like that. Here is the screenshot if I click the on/off icon. Can you tell me where to find the advanced option?

My immediate needs is to restart the server as there are a bunch of other errors I need to solve. My SSH terminal cannot load and I cannot Putty to the instance. It is frustrated that almost every time I update HA something seems to go wrong. I am pretty sure there used to be 3 dots to reboot the server but they are suddenly gone.

I think you have to choose Advanced Mode under your profile then you see the additional advanced options in that menu.

How do you run your Home Assistant? Reboot and shutdown options are only available for HA OS and HA supervised.

Yes, it is always in the Advance Mode but I still cannot see the reboot server option.

Are you using the same build?

I installed from the image of Raspery PI. This is called HA OS, right? I am pretty sure the option was there before I upgrade.

I just tried another way: I ran

service: hassio.host_reboot

on the Developer Tools. But I got an error:

Client error on /host/reboot request Cannot connect to host ssl:default [Connect call failed ('', 80)]

This IP address,, is not mine. It also appears when I click some items on left window.

I’d hate to turn off the power to make a shutdown…

Hi, which version (as in install method) of HA do you use?
It’s not present in the Core version, it is in HAOS but don’t know for the others.

Hi Nick, following your link, I installed from here: Raspberry Pi - Home Assistant

I put the image in the SD card and followed very simple process.

Here is the version I am seeing after recent upgrade:

For RPi there are 3 options.

What you show is only the frontend, says nothing about the install method.
Under System → Repairs → 3 dots → System information.

Hi Nick, sorry that I just realized there are other options in the link. I used the first option. I think it is called OS. Here is the System Information you asked:

System Information

version core-2023.5.2
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.10.11
os_name Linux
os_version 6.1.21-v7l
arch armv7l
timezone America/Los_Angeles
config_dir /config
Home Assistant Community Store
GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 4990
Installed Version 1.32.1
Stage running
Available Repositories 1285
Downloaded Repositories 13
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 10.0
update_channel stable
supervisor_version supervisor-2023.04.1
agent_version 1.5.1
docker_version 23.0.3
disk_total 28.6 GB
disk_used 10.2 GB
healthy true
supported true
board rpi4
supervisor_api failed to load: unreachable
version_api ok
installed_addons Home Assistant Google Drive Backup (0.110.4), Duck DNS (1.15.0), File editor (5.6.0), Terminal & SSH (9.7.0), Mopidy (0.2.7)
dashboards 1
resources 7
views 4
mode storage
error failed to load: timeout

You are running the Container (Docker) version of HA which doesn’t have that option.
If you want to reboot the system you have to do it from the host.

Thanks Nick. This has been extremely helpful. I never realized it was running under Docker!

Now, I took the hassle to plug in a monitor and a keyboard on the PI. Hopefully, I can use command line to reboot the server. Here is the error I am seeing now from command line:

1 Like

You are running HA OS, but somehow your installation is defective.

That is normal, HA OS is just a minimal Linux OS, and a lot of docker containers. 172.30.x.x is the docker network

But since your supervisor does not seem to be running, I don’t know a solution either.

1 Like

Thanks everyone. It was fixed. Here are the steps in case someone run into the same problem. I am sure not all commands below are needed.

  1. login (go to OS)

  2. docker pull (correct version of supervisor)

  3. exit (this will trigger a reboot)

  4. login

  5. docker pull (correct version of home assistant OS)

  6. exit

  7. core rebuild

  8. supervisor repair

  9. supervisor update

  10. host reboot

Please notice that after all this the reboot host screen came back again:

1 Like

@yang1 Sorry, my bad!
Can you please mark this topic as solved?

If you mark this as solved by selecting the answer which gave you the solution, other members will not jump in to try to help (like I just did) AND the topic can be useful for others having a similar issue.

@francisp: if it’s the container version, does it explicitly show that in the system info panel as the installation type?

Hi Nick,

No worries. Your input really lead me to the right direction.

But I think I still have one thing probably make a mistake. I used docker pull to get the latest version "...:latest" of the supervisor image. Now, the System Info showed:

Supervisor Version supervisor-2023.05.dev0901

Is this a development version? I am trying to downgrade to a stable version but it seems supervisor always loaded itself.

I am still getting some other errors in HA, that’s why I want to get rid of the development version.

Any ideas how to stop supervisor container? I tried two commands: “systemctrl” and “docker stop”. No luck.

Yes, it is a development version. But Supervisor normally updates itself, so eventually you will get a stable version again.

Latest is 2023.04.1

Thank you. I didn’t even notice that icon in the corner (using HA maximized on an ultra-wide monitor)… not the best UI choice when everything is in the center and it is waaaaay off to the right in a sea of blankness.