Home Assistant Community

How to recall existing flows

#6

Well it looks like its working mostly. I expect its my learning that has to be improved :slight_smile:

Just to check it I opened up the web interface to it and nothing is showing in the window. No nodes. Nothing.

So dropped a homeassistant node on it and opened it up and it can see the bits and pieces from HA so I am assuming the node I dropped in the flow yesterday and set up the Address etc is still in the background somewhere still with the connection data there.

0 Likes

#7

All the flows should be visible in NR… if there are no visible nodes than you don’t have any flows.

However, once done a configuration than the configured item will be visible in the configuration tab (goto top-right-menu into configuration), there you should be able to see and modify the HA config items.

0 Likes

#8

Had enough. Going to uninstall it. Thought I had it working as I could use the drop down boxes etc to see things then after a deply its coming up with connection errors again. So when and edited the node and then it comes up with connection errors from before the change of server settings and after them as well. Even deployed a blank flow in the hope it would clean out any existing flows but it still having connection errors

0 Likes

#9

yes, having the same server connect issues with latest HA, thats why I downgraded HA before the authentication.

I have all my automation running on a dedicated Node-Red RPI

0 Likes

#10

Ok due to a hiccup in trying to do something remotely I ended up currupting my main install. No problems with this as I often keep playing tand breaking things to see how it all works.

Anyways reinstalled everything again. Fresh hassio, fresh node-red and yep all working.

Did find one hiccup but more related to my network DNS.

So far so good. Even using the default hassieo/homeassistantr in the address of the components. Got a twilio component to send sms messages.

Willing to share my info with anyone if it helps.

I did think about running it on a seperate rpi but for now all good. Just purchased a 4 RPI mount so have some room to play :slight_smile:

Thanks heaps all

0 Likes

#11

Ok spoke too soon.

I suspect its something to do with the upgrade I did this morning.

Just upgraded the minor upgrade from 0.78.2 to 0.78.3 but broke node-red to HA

In my HA file I see WARNING (MainThread) [hassio.api.proxy] Unknown HomeAssistant API access!

and in my node-red I get the familar can’t communicate

So I reckon the API key is perhaps wrong. HAve restarted the whole syste,

Where can I see what API value its expecting compared to what its using?

0 Likes

#12

YOU configured the API password in your configuration.yaml on Home Assistant

In Node Red, there is a CONFIGURATION tab that will have your home assistant configuration and you can fix the API password there.

0 Likes

#13

But why would it have stopped working? I havent changed the API password in the config file nor in the tabs in node-red? it was working this morning, did the update and just come home to play again the find the usual (well hasnt been here for 24 hours) cannt connect message again

0 Likes

#14

:man_shrugging:

I would look at the logs and see if I could figure it out.

0 Likes

#15

The API thats in the config isnt the one thats used in the node read component. When I installed Node-Red on a fresh install it put a string in of about 40 charecters in the api field of a haome assistant node. My api in the config file is only 8 charecters.

I have a feeling its like a token.

0 Likes

#16

It should be.

That doesn’t sound right.

0 Likes

#17

Not sure. I thinkit gets updated from somewhere and its a token. Just removed my api password from config file and rebooterd. Its connected again and the api field is filled in again with a 40 charecter value and thats different from the one before…

0 Likes

#18

I’ve been using node red for over a year with Home Assistant…and it has always used the API password, so I don’t know what you are using.

0 Likes

#19

@Secs is correct in that the latest versions of Frenck’s hass.io Node Red addon do generate an API key at addon start to communicate with HA. How exactly this key is generated I’m not sure as the key generation pre-dates the latest changes to the HA access regarding the API password.

If you are using NotoriousDBG’s hass.io addon you should switch as it’s not maintained and I was having problems exactly as you’re describing where access was blocked after a HA restart.

If you’re using Frenck’s addon - I’m currently running into a problem where it will not connect to HA but gives no errors. After each HA reboot I need to get into the Node Red web interface, modify the HA server configuration on a node (don’t have to change it, just have to open it), then re-deploy and it starts working.

So I don’t have a solution, but at least you’re not alone in the problem.

Edit: I found this (below) when looking around, have you enabled the NR projects feature?

0 Likes

#20

Thanks Shadowdrake. I do use Frenck’s addon and the projects option is off. I am a lot happier that someone else has simalar and that I have actually had it working. I can see the huge benefit of it and will persist.

0 Likes

#21

Done it again.

Got up this morning and got the usual cant connect to hassio and password redacted error. Cant workout what changes to cause this nor can I work out how to fix it…

Will persist as when it works its great…

0 Likes

#22

Ok out of interest, I deleted the api string… Checked the debug a bit later and it said renewing the api. Checked back into the settings and yep it had filled it back in with a new api string…

0 Likes

#23

Done it again. This time when I deleted the api string it didnt rebuild it and keep going. I cannot replicate the exact sequence o either break it or fix it…

I restarted Node-Red. I had deleted the API string in home assistant node. as that seemed to fix it before

In the log I can se
[cont-init.d] 30-auto-api-token.sh: executing…
INFO: API token is incorrect in the Node-RED configuration, fixing…
[cont-init.d] 30-auto-api-token.sh: exited 0.

But on checking the node again still have an error

0 Likes

#24

I’m new to hass.io and I’ve been having pretty much the same problem with node-red. When you install Frenck’s add-on, the ‘Home Assistant’ server has the following default config that pretty much work every time:

Name: Home Assistant
Base URL: http://hassio/homeassistant
API Pass: <some long string – gets auto generated on Start/Restart>

Now regarding this error:

 [error] [server:Home Assistant] Home assistant connection failed with error: Connection to home assistant could not be established with config: http://hassio/homeassistant <password redacted>

This happens when you import or reload code. The problem is, the code has a ‘Server’ configured also called “Home Assistant”. As soon as you Deploy the code, for sure you’ll get the error above. The problem is, even if you disable or even delete the whole flow, you will still get the never ending error. To fix it, open any of the blue ‘Home Assistant’ nodes, and delete the second ‘Home Assistant’ server that was added automatically during the code import. After you delete the second instance, do a Deploy and restart node-red. It should be fixed.

Let me know if it fixes your problem

0 Likes

#25

The node is generating a config item with the server settings. Removing or disabling the node only will not help.
You have to go into the configuration tab (in Node-Red) and delete the config entry

0 Likes