How to rename users? And MQTT questions - deleting discovered devices

Is there a way to rename users? Creating and deleting user again is no option, as user is owner. Also is there a way to have multiple owner users?

On youtube - status of mqtt tasmota switches always sync for the guys immediately in hass.
I installed, installed and set up addon mqtt broker mosquito, and set up my tasmota switches for the mosquito.
Now mosquito (i guess) added switches to the homepage (without states).
I have added switches again in configuration.yaml. with state section in hopes to get the states correctly.

Now when i go configuration > integrations on top there is auto created mqtt broker mosquito - when i click on it there are no devices.

When I go to homepage, no device has correct state - all 10, which are actually 5 showin off, while in reality it is on. But the switching works.

I also added my sensors - I got about 4 out of 20 after 20 minutes waiting.
Also still no correct switch states after 20 minutes waiting.

I tried uninstall mosquito broker and installing it again in hopes to get rid of the duplicate discovered switches (not shown in configuration > integrations > mqtt mosquito broker), but that did not help.
There are some old thread about deleting devices, but it is from commandline etc.

Also sometimes tab “” is missing from the left menu, it started happening after I added configurator tab.

I tried restarting again, and got this in mosquito add log (dunno if it is current)

1543772387: Socket error on client <unknown>, disconnecting. 1543772387: New connection from on port 1883. [WARN] Not found homeassistant on local database 1543772387: Socket error on client <unknown>, disconnecting. 1543773087: New connection from on port 1883. [WARN] Not found homeassistant on local database 1543773087: Socket error on client <unknown>, disconnecting.

And then i have this in hass log

Error doing job: Task exception was never retrieved

File “/usr/local/lib/python3.6/site-packages/homeassistant/components/mqtt/”, line 808, in _raise_on_error
‘Error talking to MQTT: {}’.format(mqtt.error_string(result_code)))
homeassistant.exceptions.HomeAssistantError: Error talking to MQTT: The client is not currently connected.

Ok so I deleted the configuration > integrations > mqtt mosquito broker and again reinstalled mosquito add on and restarted (why it take minutes to begin restart after i click restart? :slight_smile: ). Now I got devices back. And even sensors all updated after few minutes.
I tried to update tasmota 6.1.1 to 6.3.0 on one switch and not it even has correct status showing. (seems more related to tasmota restart then update thought). But at least it shows as not available while the firmware update is in progress.
Hmm, even switch status is updating now.