How to restore from old backup


I’m looking for some help. I believe the type of HA I’m running is called Core, unsupervised.

I had been running a version of HA that I had last updated in September of 2022. End of December, I upgraded to the latest December 2022 version out there. This update seemed to break my setup. After reboot, the built in weather integration would break and not work. Reboot would have it work again for 10-15 mins, and it would become ‘unavailable’. Openweather I believe it is.

At this point, I was just going to roll back my install to my last full backup, from September of 2022. Problem I had, none of my backups would show up within HA. The files are there, I backed them up to my PC via Samba share. HA was so laggy or buggy that various parts wouldn’t load, which included backups pane.

I waited, and sure enough January 2023 releases came out. I updated to the first one and still experienced the weather issues and other stuff not loading, or breaking until I would reboot my Raspberry Pi that hosts my install.

Then the latest January 2023 came out and that seems to have fixed all of my loading issues. Weather now works continuously. No more needing to reboot. The kicker - NONE of my backups show up now in the interface. I am able to perform a NEW backup and see that, but I can’t see any of my old ones (prior to Jan 2023).

I wanted to add the Google Drive Home Assistant Backup thing to my install, and can’t figure out how to add the respository. Add-On Store is missing now, with no way to add it. I also see notification for:

The following integrations and platforms could not be set up:

Was the Add-On Store removed sometime between last year and now? I think I want to roll back to September 2022 backup, but don’t know how to do this, since I can’t view older backups in the interface. Were older backups somehow blocked from being able to revert back to? It’s like HA closed down outside support, removed the add on store with ability to add repositories.

What are my options here? Running on a RaspPi 4. I have all of my old backups on my PC. Would I need to find an older image of HA, reinstall from scratch, upload my old 9-2022 backup to it, and then kick off a restore?

Addons are only available if the installation method is operating system or supervised since those are the only two installation methods which include supervisor. So if you saw the addon store in the past and installed addons from it then you were on one of those two installation methods, not core.

Perhaps it would help if you shared your system info? Can click the button below to open the pop up and then click the copy button to share it:
Open your Home Assistant instance and show information about your system.

1 Like

System Information

version core-2023.1.2
installation_type Home Assistant Container
dev false
hassio false
docker true
user root
virtualenv false
python_version 3.10.7
os_name Linux
os_version 5.15.76-v7l
arch armv7l
timezone America/Chicago
config_dir /config
Home Assistant Community Store
GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 5000
Installed Version 1.29.1
Stage running
Available Repositories 1268
Downloaded Repositories 12
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
dashboards 1
resources 5
views 8
mode storage
oldest_recorder_run January 2, 2023 at 1:34 AM
current_recorder_run January 9, 2023 at 8:33 AM
estimated_db_size 376.60 MiB
database_engine sqlite
database_version 3.38.5

Ok you have a container install. Well what you’re saying makes sense then. A container type install is missing supervisor so there are no addons. The addon store is not supposed to show up in your type of install.

Supervisor is also what restores backups. So you cannot restore a backup in your type of install. You can extract one (it’s just a tar file) and then copy the contents of the config folder into your new config folder if you want. But HA has no restore option in a container install and you can’t do anything with the addons in the backup anyway.

There’s a chart here comparing the installation methods for reference:

Hi Mike,

Thank you for your response. I appreciate you breaking it down for me. Do you happen to know when this process was changed?

Last year an update broke some things, and I had to roll it back, via an older backup. I simply went to the Backups page, selected the full backup that I wanted to restore back to, hit restore and it was completed.

After this January 2023 update, I can’t even view my older backups in the interface. Now, I see the one full backup I created after updating to January 2023, but only two options. Download the file or delete the backup file…

Is there a repository of old Home Assistant Raspberry Pi images that I can use to perform a ‘new’ restore, using an old version? I’ll go that route, and restore with the 09-2022 backup that I had pulled down to a computer for safekeeping. If that still lacks the functionality, I’ll just keep stepping back.

From here on out, I’ll have to run two RaspPi settings, one for ‘production’, and one for testing. I’m kicking myself that I didn’t know this ahead of time. These are some drastic changes.

You mentioned Container install and that reminded me that I had Portainer going too. I can’t even find how to view/see/set Portainer anymore. This is wild. DuckDNS is missing too.

The process hasn’t changed. Actually the only recent change in this space is that its now possible to create a backup in container and core type installs. You still can’t restore in those types of installs but the ability to create a backup is helpful if those users want to migrate to a supervised or OS type install, since then they can just restore the backup they made. But restoring backups and installing addons has never been available for core and container type installs.

That being said, it kind of seems like you had a supervised or OS type install and now HA thinks you’re using container. That would explain why you were able to make and restore backups and see addons and now can’t. That would also explain this error:

The hassio integration is an integration with supervisor. So if that somehow disappeared it wouldn’t work correctly anymore.

I’m not really sure how that could happen. I guess its theoretically possible since all installs of HA involving docker (HAOS, Supervised and Container) all use the same image for HA. But there’s really no way supervisor could just stop running unless you made changes to the host system? What kinds of changes did you make in portainer? Or did you install docker compose or make other significant changes on the host system?

yeah, I’m not sure either. I haven 't really made any sort of major changes to my system in a very long time. My setup is pretty static, meaning I’m not bashing on it a lot.

Would having HACS installed, cause it to get pulled from Supervisor mode or whatnot?? I mentioned it already, but I was running and able to view my backups back in December. This January update removed my ability to see any backups within Backup page, and throws those two errors/notifications you mentioned.

for instance, looking thru my notes:
04/2022 - I set up DuckDNS. I can’t even see where to view/change this now after 01-2023 update
04/2022 - Blue Iris integration setup with HACS.
04/2022 - Google Calendar intergration and Google Nest integration

11/2021 - ESPHome integration, which has since changed so much that it doesn’t even work properly with my setup. My ESPHome devices are static and have not changed since 11/2021.

11/2021 - Installed Portainer. I went into supervisor panel, clicked Portainer, set protection mode to off, restarted Portainer. From my notes, all I used Portainer for, was Amcrest2MQTT setup. This allows me to intercept Amcrest doorbell presses, and publish event via MQTT.

As of 01/2023 - if I go to my Portainer admin console (HOME ASSISTANT IP:9000) I get log in page for Portainer. For some reason I can’t log into. Password is incorrect, and I’ve tried all things I have wriitten notes on…So it’s running somehow, somewhere, but I can’t even see this within Home Assistant.

Looking thru old notes from 11/2021, I have a note saying I was able to install Portainer by pasting in the repository. Now (01/2023), since add-on store is gone, I have no way to paste in repositories. HACS has this option, but when I tried to paste in Google Drive Backup for Home Assistant respository, HACS complained that this is an ‘add-on’ repository, and HACS doesn’t handle add-ons. This tells me I need to paste it into the built in Home Assistant add-on store, which is missing from my setup now.

This is all so odd…

I’ll post some more details about the errors I see under Notifications. I already shared this part:

Invalid config

The following integrations and platforms could not be set up:

Please check your config and logs.

when I click on raspberry_pi logs is says this:

Setup failed for raspberry_pi: (DependencyError(…), ‘Could not setup dependencies: hassio’)

January 9, 2023 at 8:34:32 AM – (ERROR)

Unable to set up dependencies of raspberry_pi. Setup failed for dependencies: hassio

January 9, 2023 at 8:34:32 AM – (ERROR)

When I click on hassio logs, it says this:

Can’t read Supervisor data:

January 9, 2023 at 7:19:02 PM – (WARNING) hassio - message first occurred at January 9, 2023 at 4:18:58 PM and shows up 2 times

Timeout on /store request

January 9, 2023 at 7:19:02 PM – (ERROR) hassio - message first occurred at January 9, 2023 at 8:33:49 AM and shows up 10 times

Error doing job: Task exception was never retrieved

January 9, 2023 at 8:39:00 AM – (ERROR) components/hassio/

Setup failed for raspberry_pi: (DependencyError(…), ‘Could not setup dependencies: hassio’)

January 9, 2023 at 8:34:32 AM – (ERROR)

Unable to set up dependencies of raspberry_pi. Setup failed for dependencies: hassio

January 9, 2023 at 8:34:32 AM – (ERROR)

Error during setup of component hassio

January 9, 2023 at 8:34:11 AM – (ERROR) components/hassio/

Can’t read panel info:

January 9, 2023 at 8:34:00 AM – (ERROR) hassio

Can’t read Supervisor data:

January 9, 2023 at 8:33:49 AM – (WARNING) hassio

Timeout on /supervisor/options request

January 9, 2023 at 8:33:38 AM – (ERROR) hassio

I realize this isn’t the most important thing right now but for future reference you don’t need portainer for this. There’s an amcrest2mqtt addon available.

Having portainer does now mark a system as unhealthy because it can be used to really mess up a system. Doesn’t sound like what you did with it should be causing what you’re seeing though.

Tbh this is sounding like the path of least resistance at this point. Although just a warning on this front, backups only include HA and addons. Since you set up Amcrest2MQTT via Portainer that won’t be part of your backup and you’ll have to set it up from scratch if you do this. Another reason it would be a good idea to switch to the addon once you’re running again.

Do you have a way to install an HA image and restore your backup on a separate system? Either another RPi or a VM maybe? Just to test that works ok without losing the original. And also give yourself a way to migrate the Amcrest2MQTT config over while its still running

The system can be debugged but it could be difficult. I’ve never heard of the situation you seem to be describing. If you started with an image of HA then you probably were on HAOS, have no idea how that would now leave you on container. If you do want to try and debug it you’d have to start with the host shell, either SSH’ing into it if you can or else connecting a monitor and keyboard. I would begin by simply doing docker ps -a to see what all containers exist and what status they’re in.

I have an extra Raspberry Pi that I would like to restore my 09-2022 image from. That’s great news that amcrest2mqtt is now an add-on. Since that was pretty much all I was using Portainer for (that I can remember, heh), I have no problem moving that over to a mainstream supported method (add-on store)

Do you know if there’s a repository somewhere that has old images I can grab to do this process? I’m not fluent in versions/dates, but something from 2022.

Since I can’t view backups within Home Assistant itself, I’m just going off the files I’m seeing on my PC copy I made. I’m not exactly sure what’s a ‘full’ backup , just listing largest file sizes.

12/2021 - 132 MB
5/2022 - 108 MB
6/2022 - 115 MB
6/2022 - 211 MB
7/2022 - 393 MB
9/2022 - 179 MB
12/2022 - 673 MB
1/2023 - 823 MB

There’s smaller backups in between those, I presume those are just module updates. I already posted all of my ‘major’ changes I’ve made to my system going back to 2021. I’m not sure why all of these files vary so much in file size.

I do know that something broke with the 12/2022 updates. that’s when weather would break after 5-15 minutes. Backups page would not display anything and other modules/add ons would hang (cameras for instance).

January 2023 updates brought back stability. Everything ‘works’ now, but now I lost add-on store. If that worked, I would just add amcrest2mqtt right now, run a full backup and do a clean install and lay that backup over it. That would kill off Portainer I’m thinking.

The only other option I have, is to wait for the next release, and see if it’s magically fixed. I’m not able to articulate the problem, to report this as a bug, and I haven’t come across any recent posts with anyone else having the same problem as me. Since I don’t update that often, I don’t know when exactly this add-on was removed or missing.

When I click on full logs, here’s what I see. Interesting, I see mention of addon panel:

Show full logs

2023-01-09 08:33:34.783 WARNING (MainThread) [homeassistant.setup] Setup of hassio is taking over 10 seconds.

2023-01-09 08:33:38.321 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /supervisor/options request

2023-01-09 08:33:49.321 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /os/info request

2023-01-09 08:33:49.325 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /supervisor/info request

2023-01-09 08:33:49.330 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /info request

2023-01-09 08:33:49.334 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /host/info request

2023-01-09 08:33:49.338 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /store request

2023-01-09 08:33:49.343 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /core/info request

2023-01-09 08:33:49.346 WARNING (MainThread) [homeassistant.components.hassio] Can’t read Supervisor data:

2023-01-09 08:34:00.321 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /ingress/panels request

2023-01-09 08:34:00.325 ERROR (MainThread) [homeassistant.components.hassio.addon_panel] Can’t read panel info:

2023-01-09 08:34:11.321 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /resolution/info request

2023-01-09 08:34:11.326 ERROR (MainThread) [homeassistant.setup] Error during setup of component hassio

File “/usr/src/homeassistant/homeassistant/components/hassio/”, line 587, in async_setup

File “/usr/src/homeassistant/homeassistant/components/hassio/”, line 149, in setup

File “/usr/src/homeassistant/homeassistant/components/hassio/”, line 157, in update

File “/usr/src/homeassistant/homeassistant/components/hassio/”, line 48, in _wrapper

File “/usr/src/homeassistant/homeassistant/components/hassio/”, line 481, in send_command

raise HassioAPIError()


2023-01-09 08:34:32.105 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of raspberry_pi. Setup failed for dependencies: hassio

2023-01-09 08:34:32.107 ERROR (MainThread) [homeassistant.setup] Setup failed for raspberry_pi: (DependencyError(…), ‘Could not setup dependencies: hassio’)

File “/usr/src/homeassistant/homeassistant/components/hassio/”, line 561, in _async_setup_hardware_integration

File “/usr/src/homeassistant/homeassistant/components/hassio/”, line 319, in get_os_info

2023-01-09 16:18:58.690 ERROR (MainThread) [homeassistant.components.hassio.handler] /store return code 500

2023-01-09 16:18:58.693 WARNING (MainThread) [homeassistant.components.hassio] Can’t read Supervisor data:

2023-01-09 19:19:02.122 ERROR (MainThread) [homeassistant.components.hassio.handler] /store return code 500

2023-01-09 19:19:02.126 WARNING (MainThread) [homeassistant.components.hassio] Can’t read Supervisor data:

ok, so it appears there was an issue with my latest January 2023 update.

Today, my cable internet modem died on me. I had to swap it out for a new one. In the process of getting my house back up and running, I’m trying to fix my SSL certs. I mentioned it before, but since I was unable to view/access the add-ons, I had no access to DuckDNS and Let’s Encrypt.

I figured maybe if I reboot my home assistant, it’ll update those or whatnot. I rebooted, and now everything looks better. No more notification about the hassio and raspberry pi integration. I looked, and my add-on thing is back!

Poking around, that one single January 2023 backup that I said I could see…it’s stored in /config/backups
After this reboot, I can now see all of my OLD backups again. Those are stored in /backup
I kicked off a new full backup now, and it is 175 mb. So I have no clue what was going on before. I had rebooted my home assistant a bunch of times, not sure why this reboot seemed to ‘fix’ it.

I still have more troubleshooting to do, to get my SSL/external access to work, but wanted to stop in here to provide an update. Very weird behavior with these latest backups.