How to revert/unconfigure SSL, HTTPS, DuckDNS, & LetsEncrypt

Can you revert/unconfigure HTTPS and external access in Home Assistant?
Hello, I’m new to Home Assistant and very ignorant, so please forgive me. When I set my HA instance up a year ago, i configured an https certificate and followed tutorials on DuckDNS, etc. I set it up, but it was a mistake. Other members of my house reset the router to factory default, because they are ignorant and think resetting it constantly fixes their issues–whatever those may be. Because of this, I cannot configure my modem/router as it will just be reset in a few days.

Is there way to unconfigure https? I cannot use the Home Assistant android app as it says
“Unable to connect to Home Assistant.
Server or proxy hostname lookup failed, please check that the URL is a Valid Home Assistant URL.” I also try letting it search for the HA on the local network but it indefinitely searches.
The URL I use on my desktop to access HA is the default, ‘homeassistant.local:8123’ but under Setting>Network>Home Assistant URL there is a warning under ‘local network’ that states, " Invalid local network URL:
You have configured an HTTPS certificate in Home Assistant. This means that your internal URL needs to be set to a domain covered by the certficate." And yes, Home Assistant misspelled ‘certificate’ in this instance. I have tried manually changing the local URL but it won’t let me connect to it on the HA mobile app.

I cannot find any other material on the matter of reverting. Here is the tutorial I followed a year ago.

I had the HA mobile app working back when I had https configured, and all that. But I hadn’t been able to use it properly since it could never connect after all the router settings were reverted. I removed the server I had connected and tried reconnecting it and now it’s gone forever it seems like, unable to be found by the app.

you said you can’t configure your router because it will be reset in a few days, however you don’t need a few days… can you reconfigure your router to port forward from duckdns for just long enough to log into home assistant and remove the cert/https?:

or alternatively did you have samba or ssh configured?

My internet router/modem gets factory reset every few days. I cannot port forward or change settings to use https HA. Like I said, I am very ignorant and do not know how to remove the cert/https. I have 0 coding knowledge, no linux skills besides how to update to OS. I do not know how to remove the cert/https, that is what the title of the post says, “How to unconfigure/revert cert/https.”

Surely just keep a backup of the router settings for when it gets ‘reset to default’ so all you have to do is log into the router and restore settings from the backup?

I can’t reset the router every time the other members of my house reset the router. Almost every time I log into it, it is on the page that shows up when it has been reset. I cannot be bothered to continue to change the settings of my router. I want to revert/unconfigure https.

i’m saying to do the port forward 1 time just enough to log in and remove the https. litterally 10 minutes should be plenty.

you remove the https by going to your configuration.yaml, find & remove the http section. it should look like this:

  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

once you do that, the router can reset itself till it’s heart’s content.

if you had installed samba or ssh addons, you can go in and do that using those tools and not need to do the router thing since they runon their own protocols…

It worked, thank you! But now all of my addons such as zigbee2mqtt, ewelink, studio code server, and terminal are all saying 401: unauthorized when I click on them from the sidebar. Do addons(or in my case these) need https??

all those things that are currently pointing to https: need to be changed to http:

z2m, studio code server and terminal certainly don’t need https. i can’t attest to the others because i don’t know them all but i have rarely devices that require https as a client side.

okay, how?

no one blanket way. so sorry no single easy button for you. ya got to go to each one and find where it’s configured and change it. it’s usually not hard. usually you go to it’s page, find “settings”/gear icon and rumage around until you find https or ssl

one thing…

you said you can’t open them from the left bar. can you also not open them if you go to settings->addons?

it’s possible (annoyingly) that you have an add-on caught in a catch22… where you need ssl to get to the place to remove ssl.

if that is the case, put the http: block back into configuration.yaml temporarily, navigate to the settings of those addons, in those settings, remove the ssl/https specifications, then when done, go remove the http: block from the configuration.yaml again.

for some of the addons which are largely stateless, i’d just uninstall and reinstall.

e.g. studio code server and terminal for me are stateless (ie, i didn’t configure them hardly at all and what little config i did, i don’t care about). z2m is more of a concern…

Thanks for your help, but i’m giving up. It isn’t worth it. Thanks for your time. I only use HA for a few things and I can’t fathom spending anymore time on this.

Try a full reboot, not just a restart of HA