How to set the max brightness level for an RGBWW light

In my basement bar I have a set of shelves with RGBWW puck lights (Tuya) under them with cabinets on either side. That have RGBWW LED strips (controlled with a Zigbee controller) under them. The LED strips are considerably brighter than the puck lights. I control all the lights in HA with a light group. I’m looking for a way that I can set the maximum brightness of my LED lights to 150 out of 255. This will maintain the same brightness levels across all the lights while adjusting the dimming on the light group. Can this be done?

You could create a template light that is the new LED strip.
And use a template as the brightness that limits the upper level.

I think that could work

I was hoping there was an easier way. I’ve been looking at the light template page for an hour and still don’t really understand it. I don’t get how to set up the template to also control the light color and temperature as well as the brightness.

Did you tried the new tile card?

Yep, I’m using the tile card. My issue is that I have two different lights in a group. One light’s 100% brightness is much brighter than the other light’s 100% brightness. I want to control them together using the group most of the time. So, if I have the group as the tile card and I slide the brightness to 100% then the brighter light also goes to 100% and is much brighter.

Basically, I want these values:

When the light.bar_upper_lights group slider is at 0%

  • light.basement_bar_left_cabinet_lights should be at 0/255 brightness
  • light.basement_bar_right_cabinet_lights should be at 0/255 brightness

When the light.bar_upper_lights group slider is at 100%

  • light.basement_bar_left_cabinet_lights should be at 255/255 brightness
  • light.basement_bar_right_cabinet_lights should be at 140/255 brightness

What are you using to control the lights?
Do you use a remote and an automation?

It’s wired like this

110V line from circuit breaker > Kasa light switch on the wall > 110v to 24V transformer > 24V Zigbee RGBWW controller (handles color and brightness) > 24V LED Strips

110V line from circuit breaker > Kasa light switch on the wall (same as the right lights) > 110v to 12V transformer > 12V Tuya RGBWW puck lights (using Local Tuya to control)

I will usually just use the light switch on the wall, but I also want the ability to use HA to dim the lights and change their colors together using the group. I know I can set the brightness of each to a set level and using the light switch to turn them on will always return them to that level. But, once I use the group to adjust the brightness of both lights at the same time they will then go out of sync and the right lights will be brighter than the left lights.

What if you do not use a group and instead create an automation that when left turns on the right should also turn on but with ~ 50% brightness in a template.
If this triggers on any left light changes then the right light should be in sync.
I think

But then if I use the group to set the brightness of both to 70% the left light will decrease to 70% but the right will increase from 50% to 70%

The template light is still the only way to go. How to set all parameters is in the docs, you just need to replace the input numbers from the example with the corresponding values of the actual light entity. And for the brightness, you need to apply a factor, e.g. 0.8 to make it less bright.

But just don’t use the group.
Set the brightness of one of the lights and use the automation to mirror it to the other lights.
If you have them in a group then you apparently want to use them all at the same time, right?
So instead of using them all at the same time, use one, and have the automation control the other two.

Sorry, I was having trouble grasping what you were saying but you are right, an automation solved it. My light group slider never goes to 100%, but I can live with that. For anyone else looking to do this, this is what I ended up doing. It works well.

alias: Basement Bar Upper Cabinet Lights - Set max brightness at 140
description: ""
  - platform: numeric_state
    entity_id: light.basement_bar_right_cabinet_lights
    attribute: brightness
    above: 140
condition: []
  - service: light.turn_on
      brightness: 140
      entity_id: light.basement_bar_right_cabinet_lights
mode: single