How to set times for Rachio Zones - Change default

I have the following setup. And this is all I need for this.
BUT…no matter what I put in, it kicks off the zone for 10 minutes.

How can I set the duration for these? I was going to have each zone run for 10 minutes, which is fine, but there are two zones that I can’t have run that long, I would like to change them.
Anyone know how to do this?

You won’t be able to do that using zone switches. The switches start every zone for 10 minutes, which can be changed in the Rachio configuration, but applies to all zones. Meaning if you change the default to 3 minutes, every switch will now start a 3 minute run.

One option would be to use a button and call the rachio.start_multiple_zones service, which allows you to specify a duration per zone. See the docs here.

Another option would be create a schedule in the Rachio app for the duration you need, and that will show up as a switch in HA.