How to set up HA to control Octoprint's nozzle and bed temp?

i would like to control my Ender 3’s nozzle and bed temp, using HA.
i’ve already installed mqtt and mqtt subscribe on the octoprint.
my mqtt plugin has:

my mqtt subcribe plugin is bare:

what should my config file look like?

i followed this person’s tutorial: Home Assistant Controlling Octoprint through MQTT - Chapter 1

and i can see my OctoPrint got the message but nothing executed:

You are complicating it just a bit by passing the entire REST parameters in the MQTT publish, but it can be done. the simpler method is to have a specific MQTT topic for each action and have the REST paramters set in the OctoPrint MQTT Subscribe entry. Examples:

For connect/disconnect the configuration should look like this (topic would be whatever you are sending from HA)

For nozzle/bed temp, it’s like this:

nozzle:

bed:

and for the temp setting make sure you send {“temp”:200} for example as the payload of your mqtt publish:

thanks for the screenshot but i still cant do it.
my Subscribe is exactly as yours for connect:

and to connect, i use this

octoprint recieved the mqtt but did not connect at all

i wonder if this is a permission issue somewhere.
or do i have to get an API key?

Yes, you need the API key to use the API:

yes, i have same too
image

do i have to check all of these boxes too?

Yes copy that API key to the MQTT Subscribe plugin API Key. That “Admin” user should be part of the “Admin” group so no need for the “Additional Permissions”