How to setup an IP address for a new HA instance?


I think I’m missing a document in the HA “How to” docs. I just installed the Hyper-V VM on a Windows 10 Pro machine. I start up the VM and go to http://homeassistant.local:8123 and setup a user. No problem.

When I download the HA iPhone App from the App Store, then “Scan for Servers”, nothing is found. If I enter http://homeassistant.local:8123 as “Enter Address Manually”, the system times out (“NSURL Timeout” error).

How do I expose the VM to my network in a safe way that the iPhone App can find it?

Thank you

Don’t you just look in hyper V and see what IP address was assigned to the VM?
Did you configure a default switch to actually give it network access? This is not HA specific so maybe check some generic guides for hyper V on setting up network access and setting a static IP for a VM.

@SgtBatten, thanks for the reply.

I don’t see anything that jumps out “IP Address!” in Hyper-V Network Adapter tab…

I was able to find and run the network info command inside HA itself…

In my case, substituting http://homeassistant.local:8123 with is equivalent. Entering this IP address into the iPhone app results in the same error.

I can see the IP address, but this is a reserved IP range, not a public one.

What are the steps to get the iPhone app to reach a local IP address?

Thank you

Heres the error:

right now you are using the default switch. I believe this can only give you a dynamic IP.

the 172 IP is internal and im 99% sure you can’t access home assistant using that IP anyway as it only works within the VM.

You need to create a virtual switch, configure the VM to use the virtual switch and then you can set a static ip for the VM under the advanced features section.

1 Like


I have Home Assistant setup and running following the official instructions. I installed the Hyper-V VM on a Windows 10 Pro machine.

I downloaded the Home Assistant App from the Apple App Store and installed it on my iPhone.

Upon opening, the app says “Scanning for Servers”, but it doesn’t find one and errors out with:

I found that running ha network info command was helpful to determine the IP address of the VM. Putting this IP address into the mobile app instead of http://homeassistant.local:8123 results in the same error above.

I’m connected to the same WiFi network on the server and iPhone (though I don’t think this is the issue).

Where do I go from here?

Thank you

I’ve given you some instructions here. The issue is your hyper V setup, nothing to do with HA specifically.

1 Like

@SgtBatten, thank you for the guidance.

I’m working at SAFELY creating a new Virtual Switch for the VM. This is going to require a bit of research because I have no idea how Home Assistant provides security to/for the VM.

Example: When I run security info on the HA VM, the results are…somewhat frightening.

  • Pretty sure pwned is something to be avoided
content_trust: true
force_security: false
pwned: true

I’ve given you some instructions here. The issue is your hyper V setup, nothing to do with HA specifically.

My apologies, I was…

  1. …unsure of how popular this forum was. I can see its kept tidy!
  2. …trying to get the question in front of the mobile-app-focused crowd.

No worries. I’m working on your recommend. Will post results.

Thank you again

All you are doing is configuring the VM to be accessible within your home network on a static IP address. Nothing I’ve mentioned makes it accessible outside your home.

1 Like

Ok, cool.

When I was initially creating the VSWITCH in Hyper-V, I saw “External” as the type of switch. I assumed that meant “internet accessible”. I was incorrect (Hyper-V doc).

Sweet! Thanks @SgtBatten, your suggestion worked. I created a Virtual Switch in Hyper-V. After that, opening the Mobile App showed an HA Server on the network.

I’ll PR the docs with some screenshots if the project wants it.

Thanks again

Great, just remember to setup a static IP if you ever want to access it via a LAN IP address or externally in the future. I tend to set static IPs for everything so i know where to find them on my network.

1 Like

Oddly, after setting up the new VSWITCH, I now receive this error when trying to update HA:

Any ideas for how to deal with this?

Thank you