How to setup Spotify

Hi there. Can anybody assist me with the correct yaml code for Spotify. I did try the code on the forum but when I create the code, yaml accept the code, but when I want to ad Spotify at integration, it shows an error stating that Spotify are not set up and I must follow the documentation. If anybody else has this issue and knows the correct way to set it up.

Good morning Tom, I did follow this instruction above but it does not want to install the integration with the error " Spotify was not setup, I must follow the documentation"

Did you restart after adding the configuration?

yes I did, and the configuration was approved, but when I want to integrate Spotify this message shows " Aborted

The Spotify integration is not configured. Please follow the documentation"

Can you show your (sanitised) yaml for this integration please?

I deleted your post because you did not sanitise your configuration. You shared your client_id and secret.

You also need to format your pasted code as per step 11 here: Help us help you

As well as the spotify config have you added an internal and external url?

   external_url: "https//"  
   internal_url: "https//"

No I did not ad an internal url or external url

I am new to Home Assistant. What I do not understand if I use the coding on the documentation available on Home Assistant, why it does not work. Are the setup of Home Assistant works different on different profile’s.

You need to add an internal and external URL.

I did ad an internal and external URL.
Don’t you have coding( Spotify) for yaml that I can try.

No, I don’t use it. You still have not shown your sanitised and correctly formatted config.

That’s my working config for spotify:

  client_id: !secret spotify_user
  client_secret: !secret spotify_pass

Did you create a spotify application in spotify Developer and what did you put as redirect URI there?

Thanks for the coding, this is different than mine, will try it. Yes I did create 'n Spotify profile

And what did you use as redirect URI in the spotify app you created?

I use the example on the forum


Are you using DuckDNS by any chance?

Yes I am, sort off busy setting up remote access. But I have created an account.

If you access your instance with https, then you also need to set https for the redirect URI

Unfortunately no luck so far. I have done all the recommendations suggested.