How to setup Zigbee with Hassio

Tags: #<Tag:0x00007f739b2d2b78> #<Tag:0x00007f739b2d28f8>

Hi,
I am waiting on a zigbee stick to arrive, details below and am trying to get clear how I set this up in HA, I have read lots of tutorials which contradict each other, the official instructions are so vague I am totally confused now.

I have installed zigbee2mqtt add on
On the config page for this i have:

homeassistant: true
permit_join: true
mqtt:
  base_topic: zigbee2mqtt
  server: 'mqtt://philwashere.duckdns.org'
  user: xxx
  password: xxx
serial:
  port: /dev/ttyACM0

Do i need to create users and add them to the above config?
Do i need to add anything to Home Assistants configuration.yaml?

Zigbee Stick

Thanks

First of all you need an MQTT broker like for example Mosquitto. After that, indeed you need users to be created in home assistant to connect.

Your config will not work until you have the stick as it cannot start the addon without the stick.

Oh ok.
I have HIVE-MQ already installed and in use for other purposes, can i use this with the user details of this?

Very likely that will work indeed. you need to use the address and user details for those.

Got it to work with the settings below.
I now have a problem pairing but will create a new post for that.

Thanks for the help

Home Assistant configuration.yaml file

zha:
usb_path: /dev/serial/by-id/usb-Texas_Instruments_TI_CC2531_USB_CDC___0X00124B000FFB7947-if00
database_path: /config/zigbee.db
serial:
port: >-
/dev/serial/by-id/usb-Texas_Instruments_TI_CC2531_USB_CDC___0X00124B000FFB7947-if00

Zigbee2Mqtt Config screen

data_path: /share/zigbee2mqtt
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: true
mqtt:
base_topic: zigbee2mqtt
server: 'mqtt:// my url ’
user: xxx
password: xxxx

1 Like