How to show On/Off button only on body and not in tittle

Hi all!

Maybe this is a very basic question… what I just can’t figure out how to solve it.

I have this Radio panel with the On/Off switch. The problem, is that for some reason I can’t understand, the switch is showing twice instead of just in the body. How can I solve this?

image

This is my code:

group:
 Residence Radio:
  name: Residentie Radio
  entities:
  - input_select.radio_station
  - input_select.chromecast_radio
  - script.radio
  - input_number.volume_radio
  - input_boolean.alarm_clock

input_select:
  radio_station:
    name: 'Select Radio Station:'
    options:
      - Flaixbac
      - RAC1
      - Vaughan
      - Catalunya Radio
      - LOS40
      - EUROPA FM
      - KISS FM
      - Radio Art - Sleep
      - Ambi Nature Radio
      - Calm Radio - Sleep
      - Dinamo.FM Sleep
    initial: Flaixbac
    icon: mdi:radio

  chromecast_radio:
    name: 'Select Speakers:'
    options:
      - Livingroom
      - Bedroom
      - Multiroom
    initial: Multiroom
    icon: mdi:speaker-wireless


put_number:
  volume_radio:
    name: Volume
    icon: mdi:volume-high
    min: 0
    max: 1
    step: 0.05

input_boolean:
  alarm_clock:
    name: On/Off
    initial: off
    icon: mdi:toggle-switch

automation:
  - alias: Listen Radio
    hide_entity: True
    trigger:
      - platform: state
        entity_id: input_select.radio_station
    action:
      - service: script.radio
  - alias: Set Chromecast Radio Volume
    trigger:
      platform: state
      entity_id: input_number.volume_radio
    action:
      service: media_player.volume_set
      data_template:
        entity_id: >
          {% if is_state("input_select.chromecast_radio", "Multiroom") %} media_player.multiroom
          {% elif is_state("input_select.chromecast_radio", "Bedroom") %} media_player.bathroom_speaker
          {% elif is_state("input_select.chromecast_radio", "Livingroom") %} media_player.living_room_speaker
          {% endif %}
        volume_level: '{{  states.input_number.volume_radio.state  }}'

  - alias: Stop Streaming Radio
    trigger:
      - platform: state
        entity_id: input_boolean.alarm_clock
        to: "None"
    action:
      service: media_player.media_stop
      data_template:
        entity_id: >
          {% if is_state("input_select.chromecast_radio", "Multiroom") %} media_player.multiroom
          {% elif is_state("input_select.chromecast_radio", "Bedroom") %} media_player.bathroom_speaker
          {% elif is_state("input_select.chromecast_radio", "Livingroom") %} media_player.living_room_speaker
          {% endif %}

control: hidden

group:
 Residence Radio:
  name: Residentie Radio
  control: hidden  <=== put here
  entities:
  - input_select.radio_station
  - input_select.chromecast_radio
  - script.radio
  - input_number.volume_radio
  - input_boolean.alarm_clock

How should I use this? I tried with:

input_boolean:
  alarm_clock:
    name: On/Off
    initial: off
    icon: mdi:toggle-switch
    control: hidden

And got the error:

input_boolean:
- Invalid config for [input_boolean]: [control] is an invalid option for [input_boolean]. Check: input_boolean->input_boolean->alarm_clock->control. (See ?, line ?). Please check the docs at https://home-assistant.io/components/input_boolean

In the group yaml as per above.

Thanks a lot, now it’s working!

Another quick question, how can I modify the mdi for the “Play Radio on Chromecast”?

By modifying my /config/scripts.yaml? Or in the /config/packages/radio.yaml? And how?

I think in customize.yaml

Just tried, no luck, any ideas?

automation.radio:
    friendly_name: Play Radio
    alias: Play Radio
    icon: mdi:play

My scripts.yaml file is as follows:

radio:
  alias: Play Radio
  sequence:
  - service: media_player.volume_set
    data_template:
(...)
  chromecast_radio:
    name: 'Select Speakers:'
    options:
      - Livingroom
      - Bedroom
      - Multiroom
    initial: Multiroom
    icon: mdi:speaker-wireless   <==== change here

look for new mdi icon here https://materialdesignicons.com/

For script file you have to change icon in customize.yaml

I want to change the mdi for the “Play Radio on chromecast”, which is an Script placed on /config/scripts.yaml, and right now appears with the default “scritps logo” I guess.