How to stop a fibaro roller shutter (FGRM222) at a specific postion/maximum position (Noob-Question...)

My HASS is up and running. I’m not a newbie concerning linux. But quiet new to HASS. So I ran out of ideas…

I want my FGRM222 to stop at a maximum postition (meaning the shutter goes down and has to stop about one meter off the floor). There is an obstacle where the shutter reaches the floor (flower pot). Simplest solution woud be to remove the pot, i know :wink: but as a geek, that’s not an option.

Can you lead me towards the right direction?

Your help is very appreciated

first of all, your Switch should be discovered as a cover in HA.

Than you have to setup the FGRM222 in the Openzwave to use positioning and you have to start a calibrate run in Openzwave. (read more in the Fibaro documentation)
When done, go back so HA and now you can click on the the cover and you have a little position-bar.

Looks like this. You can use this in Automations or scrips. Have fun :smiley:

Thank you kolossboss! This works already. What I want to achieve is the shutter to stop as it reaches a certain postion so it won’t hit the flower pot. Any idea on this?

For others who want to start calibration on a fgrm-222: set parameter 29 to 1 and the shutter starts a calibration session.

and i found this: I’m reading it now.

In general: Is there a generic way to solve this kind of problems? Is there a systematic or even dogmatic way of creating a solution in HASS? I want this -> I have to think in this categories -> I read that -> I then develop this solution?

1 Like

I have mine setup and calibrated, but I still haven’t figured out a way to open or close the slats. Is this supported by HA?

I have set the device to venetian blind mode and did a full calibration.

I’ve tried messing around with the open_cover_tilt and close_cover_tilt to no avail.

Bonus question : The device also showed up as a switch, not sure what that is for - for now I’ve just added a hidden attribute to it.

I’m still not able to position the slats. Not even to check the position in realtime an stop them at a specified position… No news from my side.

To reply by myself to my last question: @rpitera did a nice summary here: Home Assistant Cards

1 Like

Hey! I’m having the same issue here. Did you get any further ? Have you found a way to control the slats ?


Still having the same issue…


do you want to set the position or you have problems with controlling the slats?

For the first there is a solution making it with scenes.

look here

For the fibaro roller shutter 2 there is a config option Venetian Blind mode. You can choose what the cover will do when you give them a position: just stop, go back to previous position, open the slats

hope this will help you…


Dear All,

I just finish my installation of Shutter roller 2 and trying to include it inside HASS… it working to open and close the Venetian Blinds bout there is not control at all about the slats… with is a really lack in my point of view… I’m quite disappointed about that…

Does anyone found a work around for this issue?

Kind REgards


i also searching for a way to control the slats but not lucky.

a workaround that works for me:

write a script which set the blind level
after reaching the position add a action that open the blinds just for a second and now the flats turn arround.

the only thing you need two scripts one for open and one for close and put the ihrer direction back to open the slats…

is not really a workarround but does his job :grinning:

greetings from austria


@mr_white your link is not working…

Regarding your script, do you have it somewhere ? I’ve tried using the open/stop method, but unfortunately it doesn’t seem to work fast enough for me.


sorry about the link. its broken and I´m not able to edit my post.

I hope that is what you mean

For my living room cover this looks like:

  - service: cover.close_cover
    entity_id: cover.level
  - delay: '00:00:02'
  - service: cover.open_cover
    entity_id: cover.level
  - delay:
      milliseconds: 500
  - service: cover.stop_cover
    entity_id: cover.level

If you do this for more than one cover at the same time you should do it seperatly because of the short delays.

My slats needs about 1,2 seconds for full turn. so 500 ms is perfect to open a bit.
Do you controll more than one cover at the same time?
For me it works only if i do the covers step by step and not the same time, otherwise they are in different position after


Thanks! I actually got to something pretty close to what you have. My problem was that I was controlling several at the same time as you guessed.


Can you post your code?

First i wanted to use “group.all_cover” but it´s not working for this.