How to succesfully connected IKEA SYMFONISK Gen2 using Conbee 2 Phoscon deCONZ

I am wondering if anyone has successfully connected the SYMFONISK Gen 2 using Conbee 2 Phoscon, deCONZ, not ZHA?

I don’t use ZHA at the moment, but noticed people have them working in ZHA. A short attempt to add ZHA resulted in the adoption/migration of all my Zigbee devices by/to ZHA. As a result, I had two options:

  1. reconfigure HA to use the ZHA entities;
  2. restore a back-up.

The reason was because the old entities/devices where not responding anymore. I picked the last one and asked at their github what the status of the implementation is since there is a closed 'device request, but it’s not (let) listed at their supported device page. They pointed me to their forum, but there was nothing useful to find and I wasn’t able to create an account over there to ask.

If no one succeeded in pairing their SYMFONISK Gen2 using just Phoscon deCONZ and now-one happens to have any clue on when/if they are gone support it anytime soon, I am happy to give ZHA another try, but hopefully without huge reconfiguration work.

I have the gen2 remote working just fine with deCONZ and a Conbee 2, but I had to manually update its firmware to get all the buttons to work.

Also, I use both deCONZ and ZHA (with two different Conbee 2 radios) and devices that started on deCONZ now show up as both deCONZ and ZHA in the UI, but are actually only managed through ZHA.

:thinking: I cannot even get it paired/contacted. Do you remember if you used ZHA or phoscon to add it?

If I go to phoscon and try to add the IKEA switch, just nothing happens. When I have a bulb or outlet nearby, it pairs with that device and the Led turns red while doing so.

Before I return them, I am wondering if someone (who missed this topic earlier) managed to connected the SYMFONISK Gen 2 using Conbee 2 Phoscon (not ZHA). And if so, do you remember how cause it only seems to connect to a bulb and not the stick itself.

I’ve had no issues pairing but did not found any Blueprint for Deconz.

I’ve made one for my personal use:

@Recte Did you end up returning? I’m facing the same issue - Conbee II (not ZHA) and not able to pair the Symfonisk Gen 2 remote

I haven’t returned them, but they are not working either. Since I knew deCONZ 2.22.2 didn’t work, I decided to wait for the update. I hoped deCONZ 2.25.3 (addon version 6.23.0) would solve it, but it didn’t. It still connects to anything but the Conbee stick.

As a result you toggle a bulb or walloutlet directly and HA isn’t seeing the switch nor the event. Very annoying. Perhaps the best approach is to address it at, but I don’t have the time to start that interaction and do tests to troubleshoot the issue.

If you figure it out, please report back to the topic, I’d love to have them working.

I see my firmware version is 2672 0700 and it looks like there is a more recent version (2678 0700) here: Index of /deconz-firmware/

This post describes a way to update it: Migration from Conbee II to ConBee III - #21 by zbeez

Updated the firmware to 2678 0700, but no luck on the SYMFONISK Gen 2.
I tried do connect it with all types of switches, even though ’ TRÅDFRI remote control’ seems most likely the one to use.

Checking the Phoscon forum, some one was able to connect it about a year ago, using firmware 2672 0700. It wasn’t supported yet so there was no way to actually use it, but it at least was seen in the Phoscon environment…

Is there anyone who can give a step-by-step guidance on how they got it connected the Symfonisk Gen 2 to their ConBee II using Phoscon?

@Kensingderp I dropped the question at Phoscon. It’s connected and the reason it worked is… You have to rapidly press the connect button 4 times. I tried long press and pressing 4 and 5 times. Neither worked until I pressed it 4 times within about 1,5s.

To complete the “story”. To use it in an automation, you need to use the event trigger. There are no “build-in” triggers available. So to capture the Play button, the trigger in YAML looks like this:

alias: Play
platform: event
event_type: deconz_event
  event: 1002
  id: <your switch id>

You can find this trigger info by using the event listener under the developer tools. Too difficult? Drop the trigger above in a new automation, without the id: <your switch id>, save it, press the play button while you have your automation on your screen and tap the colored bar once it shows. There you can find ‘the switch id’.

The event codes:

  • Volume Up: 2002
  • Volume Down: 3002
  • Previous Track: 4002
  • Next Track: 5002
  • Single dot: Not available
  • Double dot: Not available

The single and double dot button don’t seem to arrive at HA at the moment.