How to switch from Raspbee II to Conbee II in ZHA?

Hello, I’d like to be able to add some integrations which utilize BLE to communicate with devices. I presently have a Phoscon Raspbee II installed in my Raspberry Pi 4, running the latest HASSIO. In order to get the Raspbee II to work, I had to add the following to my /mnt/boot/config.txt file after doing some research:


This seems to disable bluetooth on the Raspberry Pi. I’d like to switch to the Conbee II so that I don’t have to disable bluetooth. I picked one up and tried doing this by plugging it in and removing the config lines above from my config.txt, but my existing Zigbee devices which were already paired with ZHA aren’t available. I noticed a new serial device at /dev/ttyACM0 (/dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2469218-if00) which looks like the Conbee II. Is there some config file that I need to change in order to switch the radio from /dev/ttyS0 (which I think it’s currently using for the Raspbee II) to the new serial device/radio?

Your devices aren’t exactly paired with ZHA, they’re paired with the stick. Therefore, when you change sticks - unless you backup your device registrations on the Raspbee and migrate them to the conbee, they wont show up when you swap sticks. The other option is of course to resrt and rejoin all your devices after you swap sticks and confirm the new one works.

Unfortunately i never jad a Raspbee and I use Zigbee2MQTT instead of ZHA or Decons so I don’t have the exact process for your situation but according to the thread below it os at least possible.

1 Like

FYI, see related:

Until this happens will need to backup and restore ConBee/RaspBee NVRAM with Phoscon/deCONZ:

1 Like