How to switch TADO climate into "auto"mode?

I try to turn off and turn back the TADO heating to auto mode.
I don’t succeed. I probley do something wrong.
This I tried:
Switch of the heating by using the call service node:

  • Domain: climate
  • Service: turn_off

This works fine.
Now I want to put the heating back to “auto” mode (and not just turn_on)
Therea are 3 HVAC modes:

So I tried to put the climate back in auto mode using an other call service node:

  • Domain: Climate
  • service: set_hvac_mode
  • data: auto.
    This is giving an API error. I tried : {auto}, auto, {“auto”}
    Nothing worked. What am I doing wrong?

Try this

Service: climate.set_hvac_mode
Entity: climate.heating
Data:

entity_id: climate.heating
hvac_mode: auto

Thanks I do have it running.

Data {“hvac_mode”:”auto”}

Did the trick

1 Like

I’ve been using this simple but effective routine for three years without problems.
But recently (after an HA update?) it only works half.

The routine shuts off Tado with the command ‘{“hvac_mode”: “off”}’, but after closing the door it won’t turn it back on with ‘{“hvac_mode”: “auto”}’.

I see the action is triggerd in Node red but Tado is not reacting.
I enabled loggin but that gives no information at all.

I removed the Tado plugin and reinstalled it (gave credentials again), restarted HA but still it won’t start Tado back up.

Any suggestions?

been using this native NR flow for my Tado thermostat and haven’t had an issue for a couple of years…

1 Like