How to transfer data partition to usb

Hi,
Have been trying via ssh but not getting there. Can somebody point me to the right instruction how to move the data partition to an usb flash drive?
Thanks

The new 6.5 version together with the newest core have a menu option for this. I have not tried it myself, but it looks to be an easy job now.

ah that would be perfect! upgrading OS now but is taking really long already, but as always patience patience patience :slight_smile: thanks!

so was able to find the option in the menu, has been done. But how to check if this was successful? should I make a Samba connection and see?

You can use ha os info command in the ssh terminal to see the current disk in use

You could also check the supervisor > system > host card and hover your mouse over the Used Space bar and assuming you know the size of your drive, see if it matches what you expect to see.

image

Or…you could go to Configuration > Info and scroll down to the “Supervisor” section to see the same disk usage info

1 Like

wow thanks for the clear instruction!
sadly the card shows the size of the SD card. When selecting move datadisk I get the following option. Should I be able to see more to select from? And would it mean that the USB flash (exfat formatted and called CONFIG) is not recognized correctly?

Screenshot 2021-10-12 182107

A USB stick labeled CONFIG is only for importing settings to the host, and a flash drive is not going to be the best choice for this. But even if you clear that, and remove the CONFIG label, a flash drive is going to be slow. You can try it, but I have played with it myself and it doesn’t perform well.

It would be better to connect a USB connected SSD drive. It shouldn’t matter how you format it, because it is going to end up formatted as EXT

Ok sounds like a better plan (felt the usb flash getting rather warm already). Any suggestion for the usb ssd? What should i look for when buying?

Already read i don’t need an expensive one. So ordered one already and will move the core tomorrow. Thanks for now

Yeah, I forgot to add, with my flash drive test it got surprisingly hot, too. :fire:

I’ve tested with an Inland 512GB SSD nvme and this enclosure https://www.amazon.com/Vantec-Enclosure-Cable-Space-NST-205C3-SG/dp/B07SRK9H9L

I’ve also used a 2.5" SSD with a Sabrent EC-UASP enclosure

Received a Philips SSD, but when trying the datamove I get a Timeout. How do I verify if SSD is being recognized by the pi/hassio?? Repeating but thanks and really appreciating all the help!!!

Hello!
I am also testing the new Move datadisk function from UI. For this I have connected a usb hard disk (hdd) that I can see connected in the hardware list as sdb and sdb1. When I click on Move datadisk, Home Assistant returns the message: No suitable attached devices found
Do you know if the external drive must have any special characteristics to be compatible with this function?
Thanks!

4 Likes

Hi, I spent days trying to make it work with an old ssd and it was a waste of time, I bought a new Kingston A400 SSD with an UGREEN adaptor and it worked perfectly fine at the first attempt

HI,

how I can check if the datadisk is working properly?
I used the UI to move data to external SSD, but how I can check if it works? how much space is left, etc?

regrads

Did you find any solution to this Gilbert?

No, I have not succeeded, I have also tried with an SSD drive connected with an USB adapter and it still does not detect

1 Like

I am affected by the same issue with hassio 22.11.3 on Pi 4.

The disk is detected by linux as during boot, but not by homeassistant as an datadisk target. Verbatim 120GB SATA m2 external usb disk.

Interestingly, it works when the OS image is flashed to that disk and then booting homeassistant with USB boot. But I read this is not the optimal solution to set things up.

The same disk that can be used to completely boot hassio from, cannot be used as a datadisk, since it does not show up with os datadisk list. what am I doing wrong and how to fix this?


image

Edit: Just tested by adding a USB stick 128GB Sandisk. Same issue, systems detects the device, but homeassistant does not.

Edit 2: Removing any of the USB storage devices is just crashing supervisor and HA is asking me to do a full system reboot.

Open terminal goes to reconnecting... state; Storage Settings section is not loading any data to show; Hardware Settings show Unknown_error and even the UI buttons for restart/shutdown are missing.

Need to power cycle to reboot it. Is it supposed to happen when you disconnect a USB device while HA is running? USB is hotplug by definition if I am not mistaken.

I’m still the same, although I have yet to try a powered usb hard drive powered by its own power supply.

Having the same issue. HA can see the device, but gives me the “No suitable” message. I just changed my host device to something different, but I successfully used the same external USB drive on that other host device a week ago before I moved over. I’ve tried formatting in NTFS, EXT4, and FAT32 but still getting the No suitable message.

Edit: I happened to order a powered usb hub for another PC and it arrived yesterday. Gave it a shot and still not working. I’ll give it a shot with some other different types of drives later to see if they are picked up.

I’m seeing same here. I’m running HA OS on a dedicated rpi 4 w/32GB microSD card. Just plugged in Verbatim 120GB SSD stick, no partitions/formatting.

HA sees the disk as /dev/sda, but ha os datadisk list shows nothing and GUI says there are no available disks. If I try to force the move using ha os datadisk move /dev/sda, I get an error:

Error: ‘/dev/sda’ is a system disk and can’t be used!

ha hardware info:

Why is /dev/sda showing as a system disk? Seems like a bug.