How to troubleshoot failed updates

Looking back several months ago I never had any issues updating my ESPHome devices wirelessly within HA. But ever since about the time 9.x rolled out I always get random failures. Today I’m trying to deploy 11.x and that failure rate has increased where over half of my devices fail. I see this across my ESP32 and 8266 devices equally. I’ve tried moving devices to be within inches of my AP and it still fails repeatedly so I don’t think it’s about wifi signal quality. On one of my devices I just kept hitting retry and it finally worked after about a dozen times. I’ve done some googling but I haven’t found any silver bullet out there on what could be causing this. Most of what I’ve found focuses on poor wifi so I I guess I won’t rule that out but like I said I’ve tried to troubleshoot that a little already. Looking for recommendations.


Do you get the same result if you update them one-by-one?

one one of them I tried updating separately and had to try a dozen times before it updated… some of the others went second try or after a few tries