How to update HomeAssistant

HI All, I am using Homeassistant latest version on Dockers. I used following link and my installation appeared as supported in the past.
Link used for install: Installing Home Assistant Supervised on a Raspberry Pi with Debian 11
Recently, I can see my homeassistant does not appear as supported.
Is this a problem? How do I resolve this.



Any help will be greatly appreciated.
Thanks

As the link says, you need to install OS Agent.

Visit the OS Agent page and then replace the version number with the latest available, into the commands below. (i.e. replace all references to 1.2.2 with the latest available)

Execute the following commands one at a time.

wget https://github.com/home-assistant/os-agent/releases/download/1.2.2os-agent_1.2.2_linux_x86_64.deb

dpkg -i os-agent_1.2.2_linux_x86_64.deb

HI, thanks for help. I have tried as per your instructions but do get dependency error. Any help will be appreciated.

[email protected]:~$ sudo dpkg -i os-agent_1.2.2_linux_aarch64.deb
sudo: unable to resolve host HomeAssistant4: Name or service not known
Selecting previously unselected package os-agent.
(Reading database ... 22105 files and directories currently installed.)
Preparing to unpack os-agent_1.2.2_linux_aarch64.deb ...
Unpacking os-agent (1.2.2) ...
dpkg: dependency problems prevent configuration of os-agent:
 os-agent depends on udisks2; however:
  Package udisks2 is not installed.

dpkg: error processing package os-agent (--install):
 dependency problems - leaving unconfigured
Processing triggers for dbus (1.12.20-0+deb10u1) ...
Errors were encountered while processing:
 os-agent
[email protected]:~$ uname -a
Linux HomeAssistant4 5.9.0-0.bpo.5-arm64 #1 SMP Debian 5.9.15-1~bpo10+1 (2020-12-31) aarch64 GNU/Linux
[email protected]:~$

run

sudo apt install libglib2.0-bin udisks2
1 Like

sorry i am getting more errors on this
sudo apt install udisk2
sudo: unable to resolve host HomeAssistant4: Name or service not known
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package udisk2

That sounds like network errors.
Are your network working and can you ping stuff, like www.google.com?

yes i can ping all other websites.
I als did tried to download wget and it worked fine.
Thanks

Then the network has another name for your Raspi, than what the raspi thinks.
Can you ping HomeAssistant4 from another machine and is it the right IP?
The sudo command seems really stern on what the machines hostname is.

My error, it is

sudo apt  install udisks2

https://packages.debian.org/bullseye/source/udisks2

1 Like

thanks its all sorted now.
Regards