How to update Shelly Plug S firmware to latest version?

Hi,

today I got my first Shelly Plug S and wanted to integrate it into HA. However, the Shelly integration complains that my firmware is not supported, although the Shelly config says that no firmware update would be available.

Thus, I thought that this might be a bug of the Shelly integration, and opened this bug. The answer was that I have to update the device to version 20201124-092310/v1.9.0@57ac4ad8.

I thus googled how to do this, and came across this page, which explains how to perform a manual update via the device’s REST API. The URL I constructed following the instructions worked fine, but I did not end up with the above version, but a version from early 2020 (the device’s web interface shows 20200116-081720/1085-ota-firmware-for-conflicting-devices@3ea0de5b as the version). Again, the device says that no firmware update is available.

Finally, I checked out the Filebase of the Shelly support forum, which for some reason shows two files for the Plug S, but when clicking on the folder symbol, I do not see any files (see here).

Thus, my question is: How can I install the latest firmware version? Feeling pretty stupid right now :slight_smile:

Thanks
Christian

4 Likes

Go to http://archive.shelly-faq.de/

11 Likes

Thanks, that’s exactly what I was looking for. I have added that information to the integration’s documentation.

1 Like

Great! This is something Shelly doesn´t tell (in the first place).

1 Like

Had the same problem that Shelly plug did not offer an upgrade (my 1PMs did). So thank you for the post, just running the update with the convenient link the Shelly archive creates.

One more update: It turned out, that version 1.9.4 is working, however now Shelly offers to offer to 1.11. I suspect that it will stop working again after going to the newest version and thats the reason it didn’t offer an upgrade?

Not going to try it now, as I need the device running, but still curious.

I had the same problem.
After updating to 1.9.4 with the link from Maciek, I saw the additional update to v1.11.4 in the shelly app.
I also did this update and everything is working in Home assistant.

1 Like

Adding to say I appreciate the help!
Shelly Plug S not seeing any update.

  1. Used the link to the mentioned page (Shelly Firmware Archive Link Generator)
  2. Selected SHPLG-S and my IP address
  3. Selected v1.1.10 (I think this updated the device very quickly as I heard a click)
  4. In the Shelly app a new firmware was now found v1.1.11
  5. Updated using the Shelly app
  6. Automatically discovered in Home Assistant
  7. Celebrate !!
4 Likes

How do i know the ip adres of the shelly?

After added to my WIFI, i can’t find the plug anymore,…

The easiest way is probably by logging into your router - it should show all connected devices and the IPs they have been assigned.

There’s also a Shelly device finder tool (Windows). Or use a network discovery tool. Or look at the router. Or in HA once the device is integrated. Plenty of options.

Oh my. This was a lifesaver, because my Shelly Plug S similarly would not show a firmware update available, and all I got from the integration was that the firmware was incompatible!

I saw that the PR to add this to the documentation. I admit that I find it quite sad that it was closed and rejected. That kind of information is invaluable.

I have the same problem but can’t make it work. I do the update with the generator but when I check the shelly plug on its IP adress, it still is the same old firmware version. If I push update on the shelly cloud app, it seems to do the update, but the same version is still there. I tried to install the HACS shelly integration as well, but it won’t work either. Lord please help me with this :slight_smile:

Forget about the custom Shelly integration from HACS. Now with the stock Shelly integration updating is so easy:

Or if you want to do it non-smart you could go with http://archive.shelly-faq.de / http://archive.shelly-tools.de.