How to use busware CC1101 USB stick for Homematic

I’m currently a bit lost. I’m moving from fhem where I was using this Busware CC1101 USB stick without any problems. I’m now trying to get this running with What’s my best option to get my HomeMatic devices (not HM-IP) working in
It looks like the stick is not supported by the HomeMatic CCU add-on. Unfortunately I’m not able to use the HM-MOD-RPI-PCB (the slot is already blocked). Is there an alternative?

In your opinion: What’s my best/easiest option to get my HomeMatic devices working on

Have a look at Homegear. IIRC there is a Homegear addon available somewhere, but I’m not sure how well this works. If it’s an option, install Homegear on a dedicated machine with the CUL attached. With that in place the HomeMatic integration should work for you.

Thanks for the advice. I was hoping for a simpler solution but I think this is the way I’ll go.


of course i also found two addons for homegear but both are not working anymore or they run out of developement.

you are right, installing homegear on a dedicated machine is a way to integrate homematic devices into hassio.

i had the same problem and wasnt interested in setting up a second machine specialy for that job (geiz ist geil).

Then i found this project:

So i enabled the root-ssh-access to my hassos and installed the docker cointainer from cli.

and voila: could connect to homegear from the hassio integrated homematic function.

no need for any additional addon and can use my busware cul cc1101 on rpi4 with hassos

i modified the command for executing the container so it starts on every boot of my pi.

1 Like

Mhhh very interesting.
I am running a seperate PI with HomeGear just for controlling my Max! devices …

Running it on the same PI4 like my HASS would be very nice.

Could you explain how you did this?
I could pull the docker image an start it. But is could not mount folders from outside of the image “mkdir” says “mkdir: can’t create directory ‘test’: Read-only file system” if I am connected via ssh. How did you start the container in boot?
Thanks :blush: