How to use home assistant terminal cli-tool in HA-superviced - Problem solved


the update 2021.7 broke my home assistant… the gui is not starting, when looking at the running docker, there is no docker running with ports 8123, seems it is dead.
I wanted to use the hassio snapshot function to restore, to before the update. But how do I use hassio on superviced home assistant installation?

When you login it’s the real linux, just calling hassio does not work. Searched abit online, cant seem to find how to get into hassio, I know when you open the terminal in the browser it is hassio.

Okay, so home assistant still works when I open it via the ip insted of the domain. Super weird, I only updated home assistant and did not change anything on my proxy.

But for the future, does someone know how to use the hassio program? I tried to go into hassio_cli and homeassistant docker but hassio also does not work there.

Hassio has not been a term we use for over a year and a half. It is called Home Assistant OS (Hass OS for short) , not Hassio. Please stop using it. It confuses new users.

Either way your question still does not make sense. Home Assistant supervised always runs Hass OS. You are missing the web frontend.

You are running a reverse proxy that is not configured correctly. Please see the first breaking change in the 2021.7 release notes.

I searched online and found that there is a commenline tool called hassio which with you can use the snapshot function.

I tried to run hassio in the terminal app and found out it is called ha now. And it worked when I login to normal linux.

Normally I look at the change log, but this time I was busy with other stuff, so just updates.

I did not know that you would need to add a comment in the configuration.yaml for a proxy to work.

changed the thread to solved.

Always wise to read the release notes, and in particular the breaking changes, before updating.

You are totally right, it seems like the one time I don’t read changelog I get scrowed. Reminds me of the time my laptop with Arch linux was made useles because of a kernel update.

Any way thanks for the help.