How to use Rainforest Eagle sensors with Energy dashboard?

I have a Rainforest Eagle (RFA-Z109) which provides the following 3 sensors :

The “Total Meter Energy Delivered” sensor is a meter of all the kWh that have been delivered from the grid to my home.

The “Total Meter Energy Receiver” sensor is a meter of all the kWh that have been delivered from my home’s solar panels to the grid.

Both sensors are supposed to be monotonically increasing counters.

I tried to use them in the Energy dashboard as follows :

However, the result in the Energy tab is not pleasant :

In the bars under “Energy usage”, I was expecting HomeAssistant to show the net usage for each time interval. But instead, it just shows the value of each sensor, which is really high, and meaningless.

The numbers under “Energy distribution” on the right under “Grid” and “Home” don’t make sense to me, also. Neither does the number under “Net consumed from the grid”.

My question is pretty broad, but really boils down to “How can I best utilize these sensors” in the Energy tab.

Responding to myself here - I think I see why the visualization is so odd.

Due to known stability issues with the device itself that Rainforest won’t fix (the device is past end of life), I reboot the Eagle with a smartplug every 3 hours. I also restart the integration at the same time, as there are stability problems with it also.

This reboot affects the Eagle integration sensor values negatively.

For one of these two meter sensors, it behaves as follows :

Ie. there are several minutes after the reboot during which the sensor incorrectly reports a 0 value. That messes up everything in the Energy tab.

I tried just manually reloading the integration, and this problem did not show. So, it looks like the issue is that when the device reboots, the integration collects wrong meter data temporarily.

I guess the next thing to try would be to disable the integration first, then reboot the device, wait long enough for it to be up, and then reload or re-enable the integration afterwards. I’m going to try that now. Sigh.

I see what’s going on with this device.

Somehow, the “meter reading” doesn’t appear until several minutes after a reboot. During this time, it just reports “Loading” .

Looks like it takes about 5-6 minutes before it comes back and reports the data.

I’m not sure why it takes so long, or where it’s load it from (cloud ?). It should get the data over Zigbee from the meter itself. The “current usage” screen is available within less than one minute of the device booting up.

And the “Home power demand” sensor in HomeAssistant never records any bogus values (such as going to 0), unlike the other 2 sensors.

Seems this is yet another bug in the Rainforest Eagle integration. I could work around it by disabling the integration for 5-6 minutes after each reboot. But since I’m doing 8 reboots per day, that would cause a loss of 40-48 minutes of meter data per day, which is more than I’m willing to live with.

Guess this needs to be fixed in the Eagle integration. It should not report a 0 value for the meter sensors while the data is still loading …

So, there seems to be no way for me to work around these Eagle issues.
The following YAML reloads the integration, but it reloads it immediately, without the possibility of inserting a delay :

  - service: homeassistant.reload_config_entry
    data: {}
      device_id: e2ffe9059dcda09474bfaf8ada6d6c35

I also tried

  - service: homeassistant.turn_off
    data: {}
      device_id: e2ffe9059dcda09474bfaf8ada6d6c35

And the corresponding turn_on command, but they had no effect on the Eagle device integration. It is the same as a no-op.

What I need is a way to programmatically

  1. stop/disable the Eagle integration
  2. reboot the device with the smartplug
  3. wait 5 minutes for the device to be in fully ready state with the meter data
  4. restart/re-enable the Eagle integration

I have not found a way to do this - no action so far works for steps 1 and 4.

I filed a bug for the Eagle integration issue reporting 0 at Rainforest Eagle integration should never report "0" for meter sensors · Issue #80302 · home-assistant/core · GitHub .


Any luck integrating the eagle data into your energy dashboard? I just received an eagle 3 and am having the same issue.

I upgraded to the Eagle 3 and I don’t have this issue. I don’t reboot my Eagle3, unlike the previous Eagle 1st gen.