How turn on Philips TV using WOL?


After the HA update, my configuration for Philips TVs was imported into the standard integration .
But in doing so, it was no longer possible to turn on the TV, not even a button in the card.
How do I turn on my TV through the HA?

PS: Everything worked fine before the import.

1 Like

Same thing,
In Philips TV - Home Assistant says:

" The Philips TV does not always support turning on via the API. You can either turn it on via an IR blaster or on some models using Wake On LAN (WOL). To trigger this command from the entities, the integration exposes a device trigger that can be setup to execute when the media_player is asked to turn on."

But I can’t find the device trigger to set up with a scene that use an ir blaster to turn on the tv. And add a power button in the card.

  - id: philips_tv_wol
    alias: WOL Philips TV
    description: ''
    - platform: device
      device_id: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
      domain: philips_js
      type: turn_on
    condition: []
    - service: wake_on_lan.send_magic_packet
        mac: XX:XX:XX:XX:XX:XX
    mode: single

You can change WOL service to other like IR blaster command … :slight_smile:

Ohh now I know how configure the triggers for devices. Very very thanks :star_struck: :grinning_face_with_smiling_eyes:

Thanks for the above - I have a OLED905 which I really struggle to get to respond to my IR blaster (it’s a bit flakey) so hoping to set up WOL, which I believe it should support.

I’ve added the code to my automations, and see it in my automations. Entered the correct MAC but it doesn’t seem to do anything

Wondering if I’ve missed a step… do I need a specific integration to use WOL? Do I need to change settings on the TV? Perhaps I need to wire the TV?

EDIT: After testing again, it does work (I have WoWOL on, checked) but it seems that if the TV has been off for a while it stops working :frowning: Presumably it decides to turn the wifi off?

The TV must be connected to the router at all times, once it is disconnected from WiFi, you cannot wake it up via WiFi. It is better to use the LAN, but this is not always possible.

Yeah - seems pointless for it to have a WoWOL option which allows it to work on wireless, but then for it to turn off the wireless!
Ordered an ethernet cable to plug it in and check

So, my ethernet cable arrived, connected the TV to the network.
Re-installed the integration to ensure it’s using the wired connection (since IP address changed and MAC is different for the Wired)

And now… nothing… I can’t wake the TV on LAN using anything now… just doesn’t respond.
I know it’s still on the network - it’s there in my router DHCP table, but can I get it to wake with a magic packet, no I cannot… not using HA, not using a WOL app… nada

Any thoughts/suggestions?

edit: just found something here which might help - suggestion is that after WOL they need to send a remote command… will give it a go negative. Certainly no commands from HA after the WOL packet help

Try ping it every ie. 15 seconds. At least I did that on my xiaomi tv.

WOL enabled in TV? Is the network the same for TV and HA? The TV does not disconnect the interface when you turn it off? If there are lights on the TV’s network connector, they should be lit or blinking.

WOL is enabled. Network is the same. Connected via ethernet and cable. When TV is on it confirms that’s how it’s connected and that’s referenced by my router…
Can’t see any lights (but they’re right at the back)

Then it should work, maybe in the TV some settings need to be done additionally. But the WoL mechanism is the same.

Something strange is going on
I’ve just downloaded the official PhilipsTV remote app and WOL works fine using the power button in that

I’ve tried packet sniffing and not learned too much but got a few different ports the app was looking at so tried those too, plus a ping, no difference

There’s clearly something else the app is sending on top of the standard wol tho, must be

It’s probably connected to a cloud. Usually this works like that.
This is how I manage to solve my problem with a tv. Maybe it could be a help in your case.

Struggling to follow - are you saying that you continuously ping to keep the TV awake? But you still use wol to turn on your TV?

I pretty certain I’ve not got a sleep issue as it’ll turn on with the remite app and I see it in the router

I’ve enabled the Chromecast wake on LAN option too but that doesn’t seem to make any difference

One question, how did you establish which broadcast address to use in that thread?

In my case tv will go into deep sleep if I don’t ping it. So that is what I did.
Leave remote app alone it’s probably working over cloud and you want local control.
I just use static ip address on my router for tv. I’m not sure that this is essential but I done it just to be on the safe side.

Sadly I have a static IP and it’s still not working :disappointed:

It could be problem with tv. I manage my xiaomi tv to work like a charm. But I still struggling with my samsung 100+ inch tv. It cost x4 times more and it works only over cloud.

This doesn’t work for me. My YAML is as follows, domain Philips_js doesn’t work and it shows up as a media player. Any ideas?

alias: Zet Philips TV aan
description: ""
  - platform: device
    device_id: xxx
    domain: media_player
    entity_id: media_player.2021_22_philips_uhd_android_tv_2
    type: turned_on
condition: []
  - service: wake_on_lan.send_magic_packet
      mac: xxxx
      broadcast_port: 9
mode: single

hey guys i still wondering how philips remote app could swich it on. I checked - disabled internet fro TV but kept local ip, it works without internet - so its not cloud. I think its a special request via MAC because ping not available during TV sleep.