How turn on Philips TV using WOL?

Thanks for the above - I have a OLED905 which I really struggle to get to respond to my IR blaster (it’s a bit flakey) so hoping to set up WOL, which I believe it should support.

I’ve added the code to my automations, and see it in my automations. Entered the correct MAC but it doesn’t seem to do anything

Wondering if I’ve missed a step… do I need a specific integration to use WOL? Do I need to change settings on the TV? Perhaps I need to wire the TV?

EDIT: After testing again, it does work (I have WoWOL on, checked) but it seems that if the TV has been off for a while it stops working :frowning: Presumably it decides to turn the wifi off?

The TV must be connected to the router at all times, once it is disconnected from WiFi, you cannot wake it up via WiFi. It is better to use the LAN, but this is not always possible.

Yeah - seems pointless for it to have a WoWOL option which allows it to work on wireless, but then for it to turn off the wireless!
Ordered an ethernet cable to plug it in and check

So, my ethernet cable arrived, connected the TV to the network.
Re-installed the integration to ensure it’s using the wired connection (since IP address changed and MAC is different for the Wired)

And now… nothing… I can’t wake the TV on LAN using anything now… just doesn’t respond.
I know it’s still on the network - it’s there in my router DHCP table, but can I get it to wake with a magic packet, no I cannot… not using HA, not using a WOL app… nada

Any thoughts/suggestions?

edit: just found something here which might help - suggestion is that after WOL they need to send a remote command… will give it a go negative. Certainly no commands from HA after the WOL packet help

Try ping it every ie. 15 seconds. At least I did that on my xiaomi tv.

WOL enabled in TV? Is the network the same for TV and HA? The TV does not disconnect the interface when you turn it off? If there are lights on the TV’s network connector, they should be lit or blinking.

WOL is enabled. Network is the same. Connected via ethernet and cable. When TV is on it confirms that’s how it’s connected and that’s referenced by my router…
Can’t see any lights (but they’re right at the back)

Then it should work, maybe in the TV some settings need to be done additionally. But the WoL mechanism is the same.

Something strange is going on
I’ve just downloaded the official PhilipsTV remote app and WOL works fine using the power button in that

I’ve tried packet sniffing and not learned too much but got a few different ports the app was looking at so tried those too, plus a ping, no difference

There’s clearly something else the app is sending on top of the standard wol tho, must be

It’s probably connected to a cloud. Usually this works like that.
This is how I manage to solve my problem with a tv. Maybe it could be a help in your case.

Struggling to follow - are you saying that you continuously ping to keep the TV awake? But you still use wol to turn on your TV?

I pretty certain I’ve not got a sleep issue as it’ll turn on with the remite app and I see it in the router

I’ve enabled the Chromecast wake on LAN option too but that doesn’t seem to make any difference

One question, how did you establish which broadcast address to use in that thread?

In my case tv will go into deep sleep if I don’t ping it. So that is what I did.
Leave remote app alone it’s probably working over cloud and you want local control.
I just use static ip address on my router for tv. I’m not sure that this is essential but I done it just to be on the safe side.

Sadly I have a static IP and it’s still not working :disappointed:

It could be problem with tv. I manage my xiaomi tv to work like a charm. But I still struggling with my samsung 100+ inch tv. It cost x4 times more and it works only over cloud.

This doesn’t work for me. My YAML is as follows, domain Philips_js doesn’t work and it shows up as a media player. Any ideas?

alias: Zet Philips TV aan
description: ""
  - platform: device
    device_id: xxx
    domain: media_player
    entity_id: media_player.2021_22_philips_uhd_android_tv_2
    type: turned_on
condition: []
  - service: wake_on_lan.send_magic_packet
      mac: xxxx
      broadcast_port: 9
mode: single

hey guys i still wondering how philips remote app could swich it on. I checked - disabled internet fro TV but kept local ip, it works without internet - so its not cloud. I think its a special request via MAC because ping not available during TV sleep.


okay updated !

Google philips commands :wink:
You can check connection to your TV in offline mode- it should answer:


Maybe my post in this thread can give an alternate solution (more of a hack actually…)

Hey guys, just in case someone lands on this page later (like I did)…

I struggled a bit turning on my Phillips Android TV with the wake on LAN. The TV does indeed go into a deep sleep after about 10 minutes. I randomly found out though, that in that case you can use Wake On Lan to wake it up, after which you can turn it on again using the remote integration. This script uses the android remote integration. Make sure you add your TV’s mac address.

    - choose:
        - conditions:
            - condition: state
              entity_id: "remote.tv_current"
              state: "unavailable"
            - service: wake_on_lan.send_magic_packet
                mac: MAC_ADDRESS_HERE
            - repeat:
                  - delay:
                      seconds: 1
                  - condition: template
                    value_template: "{{ is_state('remote.tv_current', 'off') }}"
                until: "{{ repeat.index == 30 or is_state('remote.tv_current', 'off') }}"
    - service: remote.turn_on
        entity_id: remote.tv_current

For my TV it takes about 5 seconds to wake up after the WOL packet is send. I tried using a wait_for_trigger, but for me the state going from “unavailable” back to “off” didn’t trigger that event. This uses a loop that checks it every second for 30 seconds.

Hope this helps someone!

where have you put the code? in a script in the script section?
sorry , just need a little help , my tv works perfect with the integration but after 2-3 min it is turned off , cannot be turned on again by the integration