HowTo autodiscover 433 MHz RF devices with HomeAssistant, OpenMQTT and...?

Hi all,
it seems, that I miss some additional informations, how to autodiscover my 433 MHz devices (mainly these are power switches, so let’s focus on these…).

What I have done so far:

  • RaspberryPi 3+ with Home Assistant 9.5 / 2023.3.2
  • NodeMCU V3/ ESP8266 V3 from LoLin/
  • STX882 connected to RX-GPIO 3 / 3V / G and SRX882 V1.3 connected to D1-GPIO5 / 3V / G

In Arduino IDE 2.0.4. I added the libraries

and opened ‘main.ino’ from

I changed the config in “” for

#define MQTT_USER "mqtt"
#define MQTT_PASS "xxx"
#define MQTT_SERVER "10.1.x.x"
#define ZgatewayRF "RF"  //ESP8266, Arduino, ESP32
#define ZmqttDiscovery "HADiscovery"//ESP8266, Arduino, ESP32, Sonoff RF Bridge
#define ota_password "xxx"

and in “config_RF.h”
# define RF_RECEIVER_GPIO 13 // D7 on nodemcu // put 4 with rf bridge direct mod

and flashed my NodeMCU with “Erase flash: All flash contents”

After restart of NodeMCU I configured my WLAN settings (NodeMCU appeared in my DSL router) and
mqtt user/password/ip

In “settings/users” I added a new user “mqtt” with the password from above.
In “settings/add ons” I installed ‘Mosquitto broker’ in Home Assistant.
In “settings/integrations/MQTT” I configured

In “MQTT/settings” I configured:
server: IP address from above → 10.1.x.x
user: mqtt
password: xxx
MQTT protocol: 3.1.1
auto discovery: ON

Clicking on the 3 dots in MQTT, I set “activate new entities”

To investigate problems, I installed MQTT explorer, configured a connection successfully and had a look at messages while clicking on a 433 MHz remote.

A new message appears @ “433toMQTT” and I recognized, that this was a button I pressed before.

So far so good. But no entities will be integrated automatically. Need some help, please.

Best !
Will Code


If you are using ZgatewayRF you are going to receive a raw value and code, that doesn’t enable auto discovery, so you will have to create the sensor yourself into configuration.yaml following the examples in the docs: