Howto configure ipv6 for HA yellow

Hello there,

i heard that for using the Matter/Thread i need to configure ipv6
So i am now trying to figure out on how to configure that.

I enabled ipv6 on my wifi router and i tried with automatic settings on HA for ipv6.
But then i have more than one ipv6 adress and the dns is like ipv4 set correctly to the wifi router, but the gateway is something different.

then i switched to static and set it the way i want, but still i get more than one ip adress on info and matter server still cant start.
unfortunately matter server starts with ipv4 only but i cannot add matter/thread device.

can someone explain what one needs to do?

To my knowledge, it is not necessary to enable IPv6 on your WiFi Router for Matter or Thread (but of course IPv6 needs to be enabled for your HA).

On my HA, I have set UI->Settings->System->Network:

  • IPv6 to “automatic settings”,
  • IPv4 I have set static address/netmask as well as gateway and dns address.

For IPv6 on HA, HA will at least have one address starting with fe80. Since you have IPv6 enabled on your WiFi Router, it most likely is broadcasting out a “Prefix” for devices on your network to use which HA will take and make another IPv6 address.

If your Matter Server is not starting, provide some logs to give a hint as to what the problem may be.

i switched back to have it set to off and auto on home assistant,

matter server is starting now but i cant connect a device with matter

silicon adapter

matter server

my aqara device:

it sees that its a door sensor:

but then it says no connection to thread network:

my network setup:



i would be happy if i could get an info on how to proceed

You may not have an IPv6 problem. Those mDNS errors on veth interfaces are common and generally not an issue, but again hard to rule out Ipv6 problems.

I would disable the “Enable Router Advertisement” on your WiFi router and then restart HA and then check to see what IPv6 addresses HA says it has. If it has IPv6 addresses other than the one starting with fe80, then it is probably getting Router Advertisements from the HA OTBR which means the OTBR’s IPv6 multicast is working.

The other thing to check when commissioning is to make sure your Mobile device is connected on the same network that HA is connected to.

i did this,

restarted everything and more…

and tried again.

I still have an fe80 and a fd87 ipv6 address on my HA yellow.
and i have nothing more that could broadcast anything.

IP6 seems to be something very complicated too.
And no one has an idea on how it should work it seems.


i dont need IPv6 anymore.
I bought Zigbee Devices and they just work.
No hassle, no time loosing with technologies that dont work and never will.

Post closed

1 Like