HP iLO sensors no longer updating since last couple of upgrades


I’ve done lots of googling and I’m afraid that I can’t seem to get to the bottom of this. About a month ago when HA upgraded I noticed that the sensors associated with monitoring my HP Microserver via iLO were no longer updating. This has worked seamlessly for the last year or so previously with no other changes.

My config looks like this:

there are more sensors in that file too but you get the idea.

In the iLO logs I see that HA logs in when it first starts up, but then it never logs in again every 5 minutes like it should as defined in scan_interval:

so this was after a restart following an update this morning, you can see the XML logins from HA and I’d normally expect that to happen every 5 mins, but after that initial login nothing happens until the next restart.

Prior to the upgrade, this is what I’d see in the iLO logs with HA logging in every 5 mins:

These are the versions of HA that I’m running: image

Any advise would be massively appreciated.



Wow! I didn’t know there was an HP ILO integration. I wonder if it works with my DL360 G7.

I use the SNMP platform which is a pain to configure on the server but gets results. I mention it in case you need an alternative of last resort.

1 Like


Thanks for the tip about SNMP, I hadn’t considered that. iLO has been part of HA and has worked really well until last month. I’d rather get that working again if at all possible.


I’ve finally managed to get this working again with a workaround, basically I just use the update_entity service to run every 15 minutes and refresh the sensors that I used on my dashboard: