HP Thin client with HAOS won't boot anymore [SOLVED]

My installation worked like a charm for over a year. Since a few days it won’t come up. I have had hardware issues (1 of the 2X2GB memory bank was broke) but after solving these (I removed the faulty one) the system still won’t boot properly.
Hardware: HP T630 (1 2GB memory bank). For the moment not connected to the network, screen, keyboard
OS: HAOS (12.3 in slot A, 12.2 in slot B)
Core: 2024.6.0

Problem: server not coming up after reboot==> Booting 'Slot B (OK=1 Try=1. Rescue mode, other slot, went through many cycles. Nothing beyond this screen.
Funny (;-() enough, if I interupt booting with F10 and mess around with some settings (without changing them) and the ‘Save and exit’, the system does start up with the banner and the CLI. Also a reboot works (host reboot). But after a shutdown, I end up in the same screen (Booting slot B…).

  1. Any chance that the system cannot boot properly because of lack of memory? (It has left only 1x2GB)?
  2. What can I do (Using CLI or logging in and using SSH) to identify the root cause of not booting?

I am not a complete Noob, but clear suggestions are appreciated.

Thanks for your help!
Dave

Have you tried another hard drive ?
If you have a spare hard drive flash another system onto that like Ubuntu or even windows to see if the system boots.

Thanks Steve.

I don’t have a spare drive and I am not sure what a successful boot from a spare drive would prove?
After all I can boot from this drive, just not a cold boot.
I will perform a disk check however, see if that learns me anything.

Is the bios losing its settings?

Ah yeah I read that wrong slightly.
Like mentioned it could be a bios setting.
Have you checked the AHCI settings haven’t changed ?
I have a HP desktop mini as well and I had a similar thing happened with mine and I was messing with all sorts of settings to get it to boot I even ended up flashing a BIOS update which failed and bricked the chip ha ha which left me manually flashing the BIOS chip with a clamp which was a learning curve lol
Anyway I got it back working but installed Proxmox instead and installed Home assistant through there instead as well as some extra VMs and it’s been solid since.

Hi Arh, thanks for your answer. How could I check if the Bios loses it’s settings?
If I interupt the boot procedure and pretend to change settings in the BIOS (but leave everything as is) and ‘Save and exit’, the boot works fine. I will check the AHCI settings (have to find out what that is, and what they should be) as suggested in Steve’s answer.

I would just enter the bios and check it is booting to the correct drive, save and reboot. If it works power it down and check the bios settings for boot are the same as they were. If the settings are changing replace the battery.

I could not find any changes in settings.
I did however solve the issue by downgrading to OS 12.1 using the cli (os update --version “12.1”).
Maybe I never powered down after updates to 12.2 and later 12.3?
I have also found an issue on Github that explains what happened: GNUB 2.12

Updating BIOS maybe is a good idea.
But for now, thanks for helping!