Http failing to start

Complete noob here, so I beg for patience. :slight_smile:

I tried to import my own Let’s Encrypt certificates which I pulled off my Asus router, and for some reason, that didn’t work so well. In any case, the core failed to start http, which left me managing from the local console. I have the browser based SSH and config editors installed, but if http doesn’t start, you’re not getting that far. Probably a good idea to consider adding some robustness if the certificates fail to load.

I was able to navigate to the configuration.yaml, but there seems to be no utility available to do anything with it (no nano, etc.). If there is, I could just remove the new problem lines and be back in business after a reboot.

Thankfully, after several attempts, was able to use ha to recover a checkpoint I had luckily performed a few days back. It wasn’t ideal because I lost a few days of tinkering, but no biggie. It also took several attempts because the supervisor would only run one task at a time and the startup task would hang for a while, allowing nothing else to complete. In the end, I copied the configuration.yaml and deleted it, which allowed everything to start up. Once back in, I was able to restore the configuration.yaml.

What is the better method for getting out of this scenario in the future?

Also - are there any guides on adding ssh or samba such that I don’t have to have local console in any situation where the web daemon has gone haywire? The instructions I’ve found seem to point to other install types - they make reference to sudo and apt and HA OS seems to not have those either. I tried putting the SD card in my pc and couldn’t locate anything but the boot partition. I have WSL installed, but I couldn’t figure out how to mount it from there.

I’d like to think I understand how this works, but the HA OS is quite unlike anything I’ve encountered.